diff mbox series

[bug#61407,v2] gnu: Add font-microsoft-cascadia.

Message ID MN2PR20MB26050BC52C8A5B0D7690C257ACDE9@MN2PR20MB2605.namprd20.prod.outlook.com
State New
Headers show
Series [bug#61407,v2] gnu: Add font-microsoft-cascadia. | expand

Commit Message

Jake Leporte Feb. 10, 2023, 7:47 p.m. UTC
I apologize, the original patch I had send included some extraneous
changes I didn't intend to include.  This is an updated patch without
those extraneous changes.

---
 gnu/packages/fonts.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)


base-commit: b8f6ead5faac3c1b9a8fa6e060c00cf0917e884e
prerequisite-patch-id: 55ebfdbee35b36ac06da23b716337ecfef350452
prerequisite-patch-id: 6cb7b2d1972d3eeb5ad8b82239b17043e7263ab0
prerequisite-patch-id: 52c97b6e4d8d4b78217423a3f1323d95a609de8c
prerequisite-patch-id: 90b350ab4778843697da28bb10344a84ccacc70c
prerequisite-patch-id: 0d5a1f7cfe93822a3f3b11c19f4b2662a79cda17
prerequisite-patch-id: f6dd89498a48185e628f547b7f023a30547d8933
--
2.39.1
diff mbox series

Patch

diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 9b7d965..55d7aa8 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -1266,6 +1266,30 @@  (define-public font-adobe-source-serif-pro
 Sans Pro family.")
     (license license:silofl1.1)))

+(define-public font-microsoft-cascadia
+  (package
+    (name "font-microsoft-cascadia")
+    (version "2111.01")
+    (source (origin
+              (method url-fetch/zipbomb)
+              (uri (string-append
+                    "https://github.com/microsoft/cascadia-code/"
+                    "releases/download/v"
+                    version
+                    "/CascadiaCode-"
+                    version
+                    ".zip"))
+              (sha256
+               (base32
+                "04p72jmbafblrliy5phqi6sqi52wgzpilf3rphppxf7zdlbnizai"))))
+    (build-system font-build-system)
+    (home-page "https://github.com/microsoft/cascadia-code")
+    (synopsis "Monospaced font with programming ligatures")
+    (description
+     "Cascadia is a fun new coding font that comes bundled with Windows
+Terminal, and is now the default font in Visual Studio as well.")
+    (license license:silofl1.1)))
+
 (define-public font-fira-sans
   ;; Fira Sans v4.203 (which corresponds to Fira Mono v3.206) is the final
   ;; version to include UFO sources. It is the same version packaged by other