diff mbox series

[bug#44866] gnu: Add sbcl-deploy.

Message ID MMzr037--3-2@tuta.io
State Accepted
Headers show
Series [bug#44866] gnu: Add sbcl-deploy. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Adam Kandur Nov. 25, 2020, 2:43 p.m. UTC
From fea395c75af129e46c99847b4a38c1ddb396f1a2 Mon Sep 17 00:00:00 2001
From: Adam Kandur <rndd@tuta.io>
Date: Wed, 25 Nov 2020 17:40:55 +0300
Subject: [PATCH] gnu: Add sbcl-deploy.

* gnu/packages/lisp-xyz.scm (sbcl-deploy): New variable.
---
 gnu/packages/lisp-xyz.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

Comments

Guillaume Le Vaillant Nov. 29, 2020, 2:42 p.m. UTC | #1
Pushed as 0fac1f259196d8c7e238e0a88e51a9bf462638d0 with some
modifications. Thanks.
diff mbox series

Patch

diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index fe2af3e..1a5c1bf 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -6031,6 +6031,32 @@  cookie headers, cookie creation, cookie jar creation and more.")
 neat APIs and connection-pooling.  It is meant to supersede Drakma.")
       (license license:expat))))
 
+(define-public sbcl-deploy
+  ;; tagged branch is outdated
+  (let ((revision "1")
+        (commit "59fd49719ef651a8fc11750bcfb337f132cff75f"))
+    (package
+      (name "sbcl-deploy")
+      (version (git-version "1.0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/Shinmera/deploy")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "1vl2116z4kw2pd3qd3n6mmg8g0mnwxr9dgddk86g7j1bis1z8k9a"))))
+      (build-system asdf-build-system/sbcl)
+      (inputs
+       `(("cffi" ,sbcl-cffi)
+     ("documentation-utils" ,sbcl-documentation-utils)))
+      (home-page "https://shinmera.github.io/deploy/")
+      (synopsis "Tools to aid in the deployment of a fully standalone application.")
+      (description "This is a system to help you easily and quickly deploy standalone common lisp applications as binaries.  
+Specifically it is geared towards applications with foreign library dependencies that run some kind of GUI.")
+      (license license:artistic2.0))))
+
 (define-public cl-dexador
   (package
     (inherit (sbcl-package->cl-source-package sbcl-dexador))