diff mbox series

[bug#44601] gnu: Add python-pytelegrambotapi.

Message ID MLyZiT2--3-2@tuta.io
State Accepted
Headers show
Series [bug#44601] gnu: Add python-pytelegrambotapi. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Adam Kandur Nov. 12, 2020, 10:28 p.m. UTC

Comments

Efraim Flashner Nov. 29, 2020, 7:47 p.m. UTC | #1
I adjusted the description slightly, removed most of the propagated
inputs and put pytest in native-inputs and made the test suite run.

Thanks! Patch pushed.
diff mbox series

Patch

From 7b1ac985a886d26b7265af7eb835217c1cf72090 Mon Sep 17 00:00:00 2001
From: Adam <rndd@tuta.io>
Date: Fri, 13 Nov 2020 01:27:08 +0300
Subject: [PATCH] gnu: Add python-pytelegrambotapi.

* gnu/packages/python-xyz.scm (python-pytelegrambotapi): New variable.
---
 gnu/packages/python-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e5b8db0..db6c7f5 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -272,6 +272,31 @@  threads.")
 task of adding retry behavior to just about anything.")
     (license license:asl2.0)))
 
+(define-public python-pytelegrambotapi
+  (package
+    (name "python-pytelegrambotapi")
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-pytest" ,python-pytest)
+       ("python-py" ,python-py)
+       ("python-wheel" ,python-wheel)
+       ("python-requests" ,python-requests)
+       ("python-six" ,python-six)))
+    (version "3.7.3")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+	     (url "https://github.com/eternnoir/pyTelegramBotAPI")
+	     (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0r6xq56sr8ifqscjm2gljjr7hivfm5w798ym4gv468fwsf3x49ms"))))
+    (home-page "https://github.com/eternnoir/pyTelegramBotAPI")
+    (synopsis "Python Telegram bot api.")
+    (description "A simple, but extensible Python implementation for the Telegram Bot API.")
+    (license license:gpl2)))
+
 (define-public python-colorlog
   (package
     (name "python-colorlog")
-- 
2.28.0