diff mbox series

[bug#44274] gnu: Add emacs-powershell.el

Message ID MKiM5Yb--3-2@tuta.io
State Accepted
Headers show
Series [bug#44274] gnu: Add emacs-powershell.el | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Adam Kandur Oct. 28, 2020, 8:39 a.m. UTC
Sometimes use it for work, would be great to have in guix,

Adam Kandur

Comments

Nicolas Goaziou Oct. 28, 2020, 9:27 a.m. UTC | #1
Hello,

Adam Kandur via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/emacs-xyz.scm (emacs-powershell.el): New variable.

Thank you. Some comments follow.

> +(define-public emacs-powershell.el

I suggest to rename it emacs-powershell.

> +  (let ((revision "0")
> +        (commit "d1b3f95669343399f199f291ef76c09a0ede5e60"))
> +    (package
> +      (name "emacs-powershell.el")

See above.

> +      (build-system emacs-build-system)
> +      (arguments
> +       `(#:include '("\\.el$")))
> +      (version "master") ;; tagged branch is outdated (2015)

Version is 0.3 per main Elisp file.

Also, end of line comments start with a single semicolon. Two semicolons
are used only for full line comments. In any case, I suggest to write
the comment above `package' instead.

> +      (source
> +       (origin
> +         (method git-fetch)
> +         (uri (git-reference
> +	       (url "https://github.com/jschaf/powershell.el")

There seem to be an issue with indentation here.

> +	       (commit version)))

This should be (commit commit)

> +         (file-name (git-file-name name version))
> +         (sha256
> +          (base32 "1cxhzaaig88zhylyycvb3849r85j1ijqklnh9zbqsfl2zhpb0g5c"))))
> +      (home-page "https://github.com/jschaf/powershell.el")
> +      (synopsis "Mode for editing PowerShell scripts")

I suggest:

  Emacs mode for editing PowerShell scripts

> +      (description "@code{powershell.el} Mode is an Emacs major mode for editing and running Microsoft PowerShell files.")

I suggest:

  Powershell is an Emacs major mode…

The library is really named Powershell, and the capitalization makes it
different from PowerShell.

Could you send an updated patch?

Regards,
Nicolas Goaziou Oct. 28, 2020, 10:01 a.m. UTC | #2
Adam Kandur via Guix-patches via <guix-patches@gnu.org> writes:

> +      (arguments
> +       `(#:include '("\\.el$")))

In addition to my other comments, I don't think the section above is
needed.

Regards,
diff mbox series

Patch

From debe288267094e2eefff6083ac4d245020a4909d Mon Sep 17 00:00:00 2001
From: Adam <rndd@tuta.io>
Date: Wed, 28 Oct 2020 11:35:03 +0300
Subject: [PATCH] gnu: Add emacs-powershell.el

* gnu/packages/emacs-xyz.scm (emacs-powershell.el): New variable.
---
 gnu/packages/emacs-xyz.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 019b2c6..8470829 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -25091,6 +25091,29 @@  built-in generator package.  It provides @code{iter2-defun} and
 original package.")
     (license license:gpl3+)))
 
+(define-public emacs-powershell.el
+  (let ((revision "0")
+        (commit "d1b3f95669343399f199f291ef76c09a0ede5e60"))
+    (package
+      (name "emacs-powershell.el")
+      (build-system emacs-build-system)
+      (arguments
+       `(#:include '("\\.el$")))
+      (version "master") ;; tagged branch is outdated (2015)
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+	       (url "https://github.com/jschaf/powershell.el")
+	       (commit version)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "1cxhzaaig88zhylyycvb3849r85j1ijqklnh9zbqsfl2zhpb0g5c"))))
+      (home-page "https://github.com/jschaf/powershell.el")
+      (synopsis "Mode for editing PowerShell scripts")
+      (description "@code{powershell.el} Mode is an Emacs major mode for editing and running Microsoft PowerShell files.")
+      (license license:gpl3+))))
+
 (define-public emacs-promise
   (package
     (name "emacs-promise")
-- 
2.28.0