diff mbox series

[bug#40970] gnu: add emacs-boon

Message ID MJCK9Q.9GY8EBVY4BEJ@fastmail.com
State Accepted
Headers show
Series [bug#40970] gnu: add emacs-boon | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Elais Player April 29, 2020, 6:54 p.m. UTC
Hi,

This patch adds the emacs-boon package with changes recommended by 
Nicolas Goaziou.

Best,

--
Elais Player

Comments

Nicolas Goaziou May 1, 2020, 8:49 p.m. UTC | #1
Hello,

Elais Player <elais@fastmail.com> writes:

> This patch adds the emacs-boon package with changes recommended by
> Nicolas Goaziou.

Thank you.

> +    (description
> +     "Boon is a complete package for modal editing, which is not Evil.
> +Strong points:

Nitpick: I suggest to use a complete sentence here.

> +@itemize
> +@item Ergonomic: common commands are easy to type.
> +@item Emacs-friendly: Emacs conventions are respected as much as compatible
> +with design goals. This means that Boon integrates well with existing Emacs
> +infrastructure, and leverages it. Existing user configuration can often be
> +re-used.
> +@item Modular: No need to buy into the whole system: mix-and-match the parts

"No need" -> "no need"

Also, you need to put two spaces at the end of sentences in description.

Otherwise, LGTM.

You generated a new patch on top of the previous one. Could you merge
both, fix the above, and send one last patch?

Regards,
Nicolas Goaziou Nov. 16, 2020, 7:22 p.m. UTC | #2
Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:

> Elais Player <elais@fastmail.com> writes:
>
>> This patch adds the emacs-boon package with changes recommended by
>> Nicolas Goaziou.
>
> Thank you.
>
>> +    (description
>> +     "Boon is a complete package for modal editing, which is not Evil.
>> +Strong points:
>
> Nitpick: I suggest to use a complete sentence here.
>
>> +@itemize
>> +@item Ergonomic: common commands are easy to type.
>> +@item Emacs-friendly: Emacs conventions are respected as much as compatible
>> +with design goals. This means that Boon integrates well with existing Emacs
>> +infrastructure, and leverages it. Existing user configuration can often be
>> +re-used.
>> +@item Modular: No need to buy into the whole system: mix-and-match the parts
>
> "No need" -> "no need"
>
> Also, you need to put two spaces at the end of sentences in description.
>
> Otherwise, LGTM.
>
> You generated a new patch on top of the previous one. Could you merge
> both, fix the above, and send one last patch?

I pushed a new iteration of this patch. I'm closing this one.
diff mbox series

Patch

From a11d6a58aa6c4ccc403d0bf4955b899b8e482cd3 Mon Sep 17 00:00:00 2001
From: Elais Player <elais@fastmail.com>
Date: Wed, 29 Apr 2020 10:37:24 -0600
Subject: [PATCH] gnu: Add emacs-boon.

* gnu/packages/emacs-xyz.scm (emacs-boon): New variable.
---
 gnu/packages/emacs-xyz.scm | 67 +++++++++++++++++++++-----------------
 1 file changed, 37 insertions(+), 30 deletions(-)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 13d539e607..f9438fca10 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -22640,6 +22640,43 @@  ASCII UML sequence diagrams in Emacs, which can be embedded in source code,
 comments or emails.")
       (license license:gpl3+))))
 
+(define-public emacs-boon
+  (package
+    (name "emacs-boon")
+    (version "1.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/jyp/boon/")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1ss9bjs34q41pa0g0nbdzd8fwpjcbd2239rdlx5aykfv9v0b8j77"))))
+    (build-system emacs-build-system)
+    (propagated-inputs
+     `(("emacs-dash" ,emacs-dash)
+       ("emacs-expand-region" ,emacs-expand-region)
+       ("emacs-multiple-cursors" ,emacs-multiple-cursors)
+       ("powerline" ,emacs-powerline)
+       ("spaceline" ,emacs-spaceline)))
+    (home-page "https://github.com/jyp/boon")
+    (synopsis "Ergonomic Command Mode for Emacs")
+    (description
+     "Boon is a complete package for modal editing, which is not Evil.
+Strong points:
+
+@itemize
+@item Ergonomic: common commands are easy to type.
+@item Emacs-friendly: Emacs conventions are respected as much as compatible
+with design goals. This means that Boon integrates well with existing Emacs
+infrastructure, and leverages it. Existing user configuration can often be
+re-used.
+@item Modular: No need to buy into the whole system: mix-and-match the parts
+you want.
+@end itemize")
+    (license license:gpl3)))
+
 (define-public emacs-trashed
   (package
     (name "emacs-trashed")
@@ -22664,33 +22701,3 @@  provides a simple but convenient user interface to manage those trashed
 files.")
     (license license:gpl3+)))
 
-(define-public emacs-boon
-  (package
-    (name "emacs-boon")
-    (version "1.1")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/jyp/boon/")
-             (commit version)))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32
-         "1ss9bjs34q41pa0g0nbdzd8fwpjcbd2239rdlx5aykfv9v0b8j77"))))
-    (build-system emacs-build-system)
-    (propagated-inputs
-     `(("emacs-expand-region" ,emacs-expand-region)
-       ("spaceline" ,emacs-spaceline)
-       ("powerline" ,emacs-powerline)
-       ("emacs-dash" ,emacs-dash)
-       ("emacs-multiple-cursors" ,emacs-multiple-cursors)))
-    (home-page "https://github.com/jyp/boon")
-    (synopsis "Ergonomic Command Mode for Emacs.")
-    (description
-     "Boon brings modal editing capabilities to Emacs and...
-
-- It tries to be as ergonomic as possible.
-- It remains lightweight (~300 loc for its core.)
-- It attempts to integrate with Emacs as smoothly as possible")
-    (license license:gpl3)))
-- 
2.26.2