diff mbox series

[bug#43635] gnu: Add emacs-sqlite.

Message ID MIB7VYG--3-2@tuta.io
State Accepted
Headers show
Series [bug#43635] gnu: Add emacs-sqlite. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

kasper.andersson--- via Guix-patches" via Sept. 26, 2020, 8:36 p.m. UTC

Comments

Nicolas Goaziou Sept. 27, 2020, 12:31 p.m. UTC | #1
Hello,

Adam Kandur via Guix-patches via <guix-patches@gnu.org> writes:

> Subject: [PATCH] gnu: Add emacs-sqlite.
>
> * gnu/packages/emacs-xyz.scm (emacs-sqlite): New variable.

Thank you!

Some comments follow.

> +(define-public emacs-sqlite.el

The same should be emacs-sqlite.

> +  (let ((commit "dad42b8bbca4994be1871343dd18fd6528ee5797")
> +	(revision "1"))

You need to provide a comment explaining why you're choosing a specific
commit instead of a tagged release (in this case, that's because there
is no tagged commit).

Also, mind the indentation. (revision ...) should be vertically aligned
with (commit ...)

> +    (package
> +      (name "emacs-sqlite.el")

See above.

> +      (build-system emacs-build-system)
> +      (version (git-version "0.0.0" revision commit))

The base version is "1.0" per keyword in the main Elisp file, not
"0.0.0".

> +      (source
> +       (origin
> +         (method git-fetch)
> +         (uri (git-reference
> +	       (url "https://gitlab.com/cnngimenez/sqlite.el.git")

You can drop the ".git" suffix in the URL.

> +	       (commit commit)))
> +         (file-name (git-file-name name version))
> +         (sha256 (base32 "06ln4vijl8kii3nzc5cscgsadx1fqgxksflijd3ain83bn8g4wrd"))))

(base32 ...) should be moved on the line below.

> +      (home-page "https://gitlab.com/cnngimenez/sqlite.el.git")

Likewise, please drop the ".git" suffix.

> +      (synopsis "SQLite Interface for EmasLisp")

There's a typo in EmacsLisp, which I suggest to write "Emacs Lisp".

> +      (description "This code was retrieved from the EmacsWiki at Dicember 26, 2013. At that point was two developers:
> +    @cnngimenez
> +    @KIDD (Raimon Grau)")

This description is not useful. I suggest to use the one from EmacsWiki,
quoted here:

  @code{sqlite.el} is a simple SqliteInterface for connecting and retrieving
  information using the SQLite program through Elisp programming.  It is
  not intended as a user interface.

Could you send an updated patch?

Regards,
diff mbox series

Patch

From 3b06aaabbee774c6dc7fef7b81a96c0ef72db46a Mon Sep 17 00:00:00 2001
From: Adam <rndd@tuta.io>
Date: Sat, 26 Sep 2020 23:32:14 +0300
Subject: [PATCH] gnu: Add emacs-sqlite.

* gnu/packages/emacs-xyz.scm (emacs-sqlite): New variable.
---
 gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index cfef767..52744b1 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -24733,3 +24733,25 @@  web development.")
       ;; file and the header of the main elisp file which indicates
       ;; that it is licensed under the GPL version 3 or later.
       (license (list license:mpl2.0 license:gpl3+)))))
+
+(define-public emacs-sqlite.el
+  (let ((commit "dad42b8bbca4994be1871343dd18fd6528ee5797")
+	(revision "1"))
+    (package
+      (name "emacs-sqlite.el")
+      (build-system emacs-build-system)
+      (version (git-version "0.0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+	       (url "https://gitlab.com/cnngimenez/sqlite.el.git")
+	       (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256 (base32 "06ln4vijl8kii3nzc5cscgsadx1fqgxksflijd3ain83bn8g4wrd"))))
+      (home-page "https://gitlab.com/cnngimenez/sqlite.el.git")
+      (synopsis "SQLite Interface for EmasLisp")
+      (description "This code was retrieved from the EmacsWiki at Dicember 26, 2013. At that point was two developers:
+    @cnngimenez
+    @KIDD (Raimon Grau)")
+      (license license:gpl3+))))
-- 
2.28.0