diff mbox series

[bug#45761] gnu: Add mcg.

Message ID MF1bOaopUKUnfqs7K1aRQRywXoUGuAqtdFl3oK49_RC60XTU52nZyQxPS0esiCPP1rxkNsvQgCEgxPrw_Q_WvdU7so7SEe7MuMeIt2dGL_U=@protonmail.com
State Accepted
Headers show
Series [bug#45761] gnu: Add mcg. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Noah Evans Jan. 10, 2021, 9:15 p.m. UTC
Here is an updated patch removing erroneous dependency and tweaking a few things based on feedback for my other patch.

From 7980069c2b75a69755c922c0e10f1977881e25b0 Mon Sep 17 00:00:00 2001
From: Noah Evans <noah@nevans.me>
Date: Sun, 10 Jan 2021 15:39:40 -0500
Subject: [PATCH] gnu: Add mcg.

* gnu/packages/mpd.scm (mcg): New variable.
---
gnu/packages/mpd.scm | 51 ++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 51 insertions(+)

--
2.30.0
diff mbox series

Patch

diff --git a/gnu/packages/mpd.scm b/gnu/packages/mpd.scm
index 6066913f16..7a40aaf14f 100644
--- a/gnu/packages/mpd.scm
+++ b/gnu/packages/mpd.scm
@@ -10,6 +10,7 @@ 
;;; Copyright © 2020 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2020 Lars-Dominik Braun <lars@6xq.net>
;;; Copyright © 2020 Simon Streit <simon@netpanic.org>
+;;; Copyright © 2021 Noah Evans <noah@nevans.me>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -460,3 +461,53 @@  of the music library will be created to provide a hierarchy of albums and
artists along with albumart.")
(home-page "https://github.com/cdrummond/cantata")
(license license:gpl3+)))
+
+(define-public mcg
+ (package
+ (name "mcg")
+ (version "2.1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://gitlab.com/coderkun/mcg/-/archive/v"
+ version "/mcg-v" version ".tar.gz"))
+ (sha256
+ (base32
+ "0fi32jwms5qa36jw45m13f07b5f4ivip7xy7dcks6nv4mlmp6rv3"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("glib:bin" ,glib "bin")
+ ("gobject-introspection" ,gobject-introspection)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("avahi" ,avahi)
+ ("dconf" ,dconf)
+ ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
+ ("gtk+" ,gtk+)
+ ("python-pygobject" ,python-pygobject)))
+ (arguments
+ `(#:imported-modules ((guix build glib-or-gtk-build-system)
+ ,@%python-build-system-modules)
+ #:modules ((guix build python-build-system)
+ ((guix build glib-or-gtk-build-system) #:prefix glib-or-gtk:)
+ (guix build utils))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'wrap-program
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((prog (string-append (assoc-ref outputs "out")
+ "/bin/mcg")))
+ (wrap-program prog
+ `("PYTHONPATH" = (,(getenv "PYTHONPATH")))
+ `("GI_TYPELIB_PATH" = (,(getenv "GI_TYPELIB_PATH"))))
+ #t)))
+ (add-after 'wrap-program 'glib-or-gtk-wrap
+ (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-wrap)))))
+ (synopsis "Covergrid for the MPD")
+ (description
+ "mcg (CoverGrid) is a client for the Music Player Daemon (MPD), focusing
+on albums instead of single tracks. It is not intended to be a replacement
+for your favorite MPD client but an addition to get a better
+album-experience.")
+ (home-page "https://gitlab.com/coderkun/mcg")
+ (license license:gpl3+)))