diff mbox series

[bug#53708] Fix Elixir substitution error

Message ID MDTMfZulrEpqCaZTOJkuI-S4MMlHtvldNBAoXMnyEszZAGG56bIbeHmkR2L1Q1yonj9EV1uij3gGc6i-bQdoHm0L9F-mjP55g9B6k2IEAX4=@evrl.com
State Accepted
Headers show
Series [bug#53708] Fix Elixir substitution error | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Cees de Groot Feb. 1, 2022, 7:16 p.m. UTC
From d9860a374c5b6e5b992439a232e6897bfde1e334 Mon Sep 17 00:00:00 2001
From: Cees de Groot <cg@evrl.com>
Date: Tue, 1 Feb 2022 14:12:17 -0500
Subject: [PATCH] Fix regex for ERTS_BIN substitution in Elixir

Something must have gone wrong during testing of the ELixir 1.13.2 patch I submitted last week. Apart from #53707, I also found out that the whole substitution regex did not work. This works better - it is still more brittle than I like, but apparently `substitute*`
does not work with fully anchored regexes.


---
 gnu/packages/elixir.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

--
2.34.0

Comments

Ludovic Courtès Feb. 14, 2022, 2:51 p.m. UTC | #1
Hi,

Cees de Groot <cg@evrl.com> skribis:

>>From d9860a374c5b6e5b992439a232e6897bfde1e334 Mon Sep 17 00:00:00 2001
> From: Cees de Groot <cg@evrl.com>
> Date: Tue, 1 Feb 2022 14:12:17 -0500
> Subject: [PATCH] Fix regex for ERTS_BIN substitution in Elixir
>
> Something must have gone wrong during testing of the ELixir 1.13.2 patch I submitted last week. Apart from #53707, I also found out that the whole substitution regex did not work. This works better - it is still more brittle than I like, but apparently `substitute*`
> does not work with fully anchored regexes.

I adjusted the commit log and applied it.

Thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/elixir.scm b/gnu/packages/elixir.scm
index fae8279e5c..55e17f2901 100644
--- a/gnu/packages/elixir.scm
+++ b/gnu/packages/elixir.scm
@@ -70,7 +70,7 @@  (define-public elixir
                 (("#!/bin/sh")
                  (string-append "#!" (search-input-file inputs "/bin/sh"))))
               (substitute* "bin/elixir"
-                (("^ERTS_BIN=$")
+                (("ERTS_BIN=\n")
                  (string-append
                   "ERTS_BIN="
                   ;; Elixir Releases will prepend to ERTS_BIN the path of