From caee73b8ca06da62b3cd778ccc7ecfaf13bc4508 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Oskar=20K=C3=B6=C3=B6k?= <oskarkook@maatriks.ee>
Date: Mon, 27 Jan 2020 14:13:16 +0200
Subject: [PATCH] gnu: elixir: Update to 1.10.0.
* gnu/packages/elixir.scm (elixir): Update to 1.10.0.
* gnu/packages/patches/elixir-path-length.patch: Update patch so it can
be applied to v1.10.0 source
---
gnu/packages/elixir.scm | 4 ++--
gnu/packages/patches/elixir-path-length.patch | 8 ++++----
2 files changed, 6 insertions(+), 6 deletions(-)
@@ -33,7 +33,7 @@
(define-public elixir
(package
(name "elixir")
- (version "1.9.4")
+ (version "1.10.0")
(source
(origin
(method git-fetch)
@@ -42,7 +42,7 @@
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1l4318g35y4h0vi2w07ayc3jizw1xc3s7hdb47w6j3iw33y06g6b"))
+ (base32 "1fz22c2jqqm2jvzxar11bh1djg3kqdn5rbxdddlz0cv6mfz7hvgv"))
(patches (search-patches "elixir-path-length.patch"))))
(build-system gnu-build-system)
(arguments
@@ -5,11 +5,11 @@ after the substitution is made.
--- a/Makefile
+++ b/Makefile
-@@ -213,6 +213,7 @@
- TEST_ERLS = $(addprefix $(TEST_EBIN)/, $(addsuffix .beam, $(basename $(notdir $(wildcard $(TEST_ERL)/*.erl)))))
+@@ -265,6 +265,7 @@ format: compile
+ $(call FORMAT)
test_formatted: compile
-+ bin/elixir bin/mix format lib/mix/lib/mix/scm/git.ex
- bin/elixir bin/mix format --check-formatted
++ $(call FORMAT,lib/mix/lib/mix/scm/git.ex)
+ $(call FORMAT,--check-formatted)
test_erlang: compile $(TEST_ERLS)
--
2.25.0