diff mbox series

[bug#51923,v2] gnu: Add megapixels.

Message ID LZX-lj6Nr3kpduKTZ_JCAsyeTcuOCP9u20WYK-S96PIQsE6Ul2aF-zc3oKo267N9Yx_Y3Aea_A6oUCjglN_-Gxa4znVmT7I46V3Ms9pJVag=@protonmail.com
State New
Headers show
Series [bug#51923,v2] gnu: Add megapixels. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

phodina Nov. 29, 2021, 11:02 a.m. UTC
Hi Tobias,

thanks for the review. Please see the attached updated patch.

Have you had time to test it?

Petr

Comments

Tobias Geerinckx-Rice Nov. 29, 2021, 2:39 p.m. UTC | #1
Petr,

phodina 写道:
> thanks for the review. Please see the attached updated patch.

Thanks!

‘a camera application’; ‘JPEG files’; but that can be tweaked by 
the final committer.

> Have you had time to test it?

Can I?  Does it run on real (& x86) computers?  How?

I assumed that it didn't.  That's why I suggested adding ‘for 
mobile devices’.  I don't own any.

λ 
/gnu/store/dn1780g27gcshqfmxilvc96kg0x72x6h-megapixels-1.3.0/bin/megapixels
Renderdoc not found
Could not read device name from device tree
Could not find any config file
λ

(And the ‘--help’ option is broken.  :-/)

Kind regards,

T G-R
Ludovic Courtès Dec. 10, 2021, 2:24 p.m. UTC | #2
Hi Tobias,

What do you think are the next steps for this patch?

TIA!

Ludo’.

Tobias Geerinckx-Rice <me@tobias.gr> skribis:

> Petr,
>
> phodina 写道:
>> thanks for the review. Please see the attached updated patch.
>
> Thanks!
>
> ‘a camera application’; ‘JPEG files’; but that can be tweaked by the
> final committer.
>
>> Have you had time to test it?
>
> Can I?  Does it run on real (& x86) computers?  How?
>
> I assumed that it didn't.  That's why I suggested adding ‘for mobile
> devices’.  I don't own any.
>
> λ
> /gnu/store/dn1780g27gcshqfmxilvc96kg0x72x6h-megapixels-1.3.0/bin/megapixels
> Renderdoc not found
> Could not read device name from device tree
> Could not find any config file
> λ
>
> (And the ‘--help’ option is broken.  :-/)
>
> Kind regards,
>
> T G-R
Maxim Cournoyer Jan. 4, 2023, 12:42 a.m. UTC | #3
Hi Petr,

phodina <phodina@protonmail.com> writes:

> Hi Tobias,
>
> thanks for the review. Please see the attached updated patch.
>
> Have you had time to test it?

I wanted to try it out, but it doesn't apply cleanly anymore.  Would you
mind submitting a rebased patch?
phodina Jan. 4, 2023, 1:25 a.m. UTC | #4
Hi Maxim,

it's indeed quite old and I'm working on Pine64 devices so I'll try to send an updated patch soon.

----
Petr

-------- Original Message --------
On Jan 4, 2023, 1:42 AM, Maxim Cournoyer wrote:

> Hi Petr,
>
> phodina <phodina@protonmail.com> writes:
>
>> Hi Tobias,
>>
>> thanks for the review. Please see the attached updated patch.
>>
>> Have you had time to test it?
>
> I wanted to try it out, but it doesn't apply cleanly anymore. Would you
> mind submitting a rebased patch?
>
> --
> Thanks,
> Maxim
diff mbox series

Patch

From c27ef7829f5f3c3198118751729583acd8eb05c6 Mon Sep 17 00:00:00 2001
From: Petr Hodina <phodina@protonmail.com>
Date: Sun, 3 Oct 2021 23:16:11 +0200
Subject: [PATCH v2] gnu: Add megapixels.

* gnu/packages/gnome.scm (megapixels): New variable.

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 19520f335a..a868ac462a 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -63,6 +63,7 @@ 
 ;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
 ;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
 ;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
+;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1137,6 +1138,57 @@  freedesktop.org desktop notification specification.")
     (home-page "https://wiki.gnome.org/Projects/NotificationDaemon")
     (license license:gpl2+)))
 
+(define-public megapixels
+  (package
+    (name "megapixels")
+    (version "1.3.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "http://gitlab.com/postmarketos/megapixels")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "0dagp1sh5whnnllrydk7ijjid0hmvcbdm8kkzq2g168khdfn80jm"))))
+    (build-system meson-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'install 'patch-paths
+           (lambda* (#:key inputs #:allow-other-keys)
+             (let ((out (assoc-ref %outputs "out"))
+                   (paths (map
+                           (lambda (input)
+                             (string-append (assoc-ref inputs input) "/bin"))
+                           '("coreutils" "imagemagick"))))
+               (wrap-program
+                   (string-append out "/share/megapixels/postprocess.sh")
+                 `("PATH" prefix ,paths))))))))
+    (native-inputs
+     `(("cmake" ,cmake)
+       ("coreutils" ,coreutils)
+       ("desktop-file-utils" ,desktop-file-utils) ; for update-desktop-database
+       ("glib:bin" ,glib "bin")         ; glib-compile-schemas, etc.
+       ("gtk:bin" ,gtk "bin")           ; for gtk-update-icon-cache
+       ("imagemagick" ,imagemagick)
+       ("libtiff" ,libtiff)
+       ("pkg-config" ,pkg-config)
+       ("zbar" ,zbar)))
+    (inputs
+     `(("gtk" ,gtk)
+       ("imagemagick" ,imagemagick)
+       ("libhandy" ,libhandy)
+       ("libraw" ,libraw)
+       ("perl-image-exiftool" ,perl-image-exiftool)))
+    (synopsis "Camera applications for mobile devices")
+    (description "This package provides camera application for mobile devices
+that captures a 5 frame burst of raw frames that are later postprocessed and
+saved as jpg files.")
+    (home-page "http://gitlab.com/postmarketos/megapixels")
+    (license license:gpl3+)))
+
 (define-public mm-common
   (package
     (name "mm-common")

base-commit: b7b982228a7256afcb83d0b05a098139c2e1a644
-- 
2.33.0