diff mbox series

[bug#59852] LXI protocol

Message ID JOa0JrizoCuQsmT0nIIGlUfjAZAJEKJhtey80c1wUl3Xdr6ioOBeCaJVQQXbVpFrSnf4_6NGWT6NOCUkgxOBhkFlRT3b-2W_l_Xygp6Wpkc=@protonmail.com
State New
Headers show
Series [bug#59852] LXI protocol | expand

Commit Message

phodina Dec. 6, 2022, 3:19 a.m. UTC
Hello,

these patches add tools to control laboratory equipment remotely (e.g. osciloscope, power supply, etc.).

----
Petr

Comments

Nicolas Goaziou April 23, 2023, 5:03 p.m. UTC | #1
Hello,

phodina via Guix-patches via <guix-patches@gnu.org> writes:


> these patches add tools to control laboratory equipment remotely (e.g.
> osciloscope, power supply, etc.).

I updated both packages to their latest release, reformatted them, fixed
build for lxi-tools and pushed everything.

Thank you.

Regards,
diff mbox series

Patch

From cc294ff8c4db2bc6a3f01402c45948bff10d1373 Mon Sep 17 00:00:00 2001
From: Petr Hodina <phodina@protonmail.com>
Date: Sat, 3 Dec 2022 10:21:45 +0100
Subject: [PATCH 2/2] gnu: Add lxi-tools.

* gnu/packages/hardware.scm (lxi-tools): New variable.

diff --git a/gnu/packages/hardware.scm b/gnu/packages/hardware.scm
index 64e45dffb8..bbd0fa4d31 100644
--- a/gnu/packages/hardware.scm
+++ b/gnu/packages/hardware.scm
@@ -62,6 +62,7 @@  (define-module (gnu packages hardware)
   #:use-module (gnu packages high-availability)
   #:use-module (gnu packages libusb)
   #:use-module (gnu packages linux)
+  #:use-module (gnu packages lua)
   #:use-module (gnu packages lxqt)
   #:use-module (gnu packages mtools)
   #:use-module (gnu packages package-management)
@@ -81,6 +82,7 @@  (define-module (gnu packages hardware)
   #:use-module (gnu packages qt)
   #:use-module (gnu packages scanner)
   #:use-module (gnu packages security-token)
+  #:use-module (gnu packages readline)
   #:use-module (gnu packages tls)
   #:use-module (gnu packages video)
   #:use-module (gnu packages virtualization)
@@ -1367,3 +1369,30 @@  (define-public liblxi
 protocols for modern instrumentation and data acquision systems using
 Ethernet.")
     (license license:bsd-3)))
+
+(define-public lxi-tools
+  (package
+    (name "lxi-tools")
+    (version "2.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+          (url "https://github.com/lxi-tools/lxi-tools")
+          (commit (string-append "v" version))))
+       (sha256
+        (base32
+         "17l70b8whwp0a7j23vsrav1abjzhw78k7rg77q78q07rdqn9fwnd"))))
+    (build-system meson-build-system)
+       (native-inputs (list cmake pkg-config readline))
+       (inputs (list liblxi lua))
+    (home-page
+     "https://lxi-tools.github.io/")
+    (synopsis
+     "LAN eXtensions for Instrumentation tools")
+    (description
+     "This package provides tools for LAN eXtensions for Instrumentation
+based on the LXI Consortium standard which defines the communication
+protocols for modern instrumentation and data acquision systems using
+Ethernet.")
+    (license license:bsd-3)))
-- 
2.38.1