diff mbox series

[bug#49703,v2] gnu: Add rust-rot8-0.1.

Message ID Ir9JtPABWU0XRM45Q-qtf4bVKPK8v6rRihWDYdCz4twyFxRMsTeItk5YYpOpVhMrG0OfX91RYpIIel-aab_mh0cd8FIZF0kspKnwPZ9ncZQ=@protonmail.com
State New
Headers show
Series [bug#49703,v2] gnu: Add rust-rot8-0.1. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

phodina July 25, 2021, 6:44 p.m. UTC
* gnu/packages/crates-io.scm (rust-rot8-0.1): New variable.
---

--
2.31.1

Comments

phodina Sept. 18, 2021, 8:02 a.m. UTC | #1
Hi Xinglu,

anything else to be fixed to upstream this patch?

Petr
Xinglu Chen Sept. 20, 2021, 12:03 p.m. UTC | #2
On Sat, Sep 18 2021, phodina wrote:

> Hi Xinglu,
>
> anything else to be fixed to upstream this patch?

Sorry for taking so long to reply!  The patch looks good, except that
the description should consist of full sentences (the first sentence
doesn’t have a subject), something like:

  This Rust library implements automatic rotation for modern Linux
  screen and input device.  Compatible with wayland and X11.  Uses
  built-in accelerometer with configurable threshold.

The person who commits the patch (I don’t have commit access) can
probably adjust the description for you, so you don’t have to send a
reroll just for this small change.  :-)
phodina Sept. 20, 2021, 3:20 p.m. UTC | #3
On Monday, September 20th, 2021 at 2:03 PM, Xinglu Chen <public@yoctocell.xyz> wrote:

> On Sat, Sep 18 2021, phodina wrote:
>
> > Hi Xinglu,
> >
> > anything else to be fixed to upstream this patch?
>
> Sorry for taking so long to reply! The patch looks good, except that
>
> the description should consist of full sentences (the first sentence
>
> doesn’t have a subject), something like:
>
> This Rust library implements automatic rotation for modern Linux
>
> screen and input device. Compatible with wayland and X11. Uses
>
> built-in accelerometer with configurable threshold.
>
> The person who commits the patch (I don’t have commit access) can
>
> probably adjust the description for you, so you don’t have to send a
>
> reroll just for this small change. :-)

Thanks! I've looked into the [1] so I hope to write better synopses and description according to the guidelines.

Thanks for your patience and help!

Regards
Petr

[1] https://guix.gnu.org/manual/en/html_node/Synopses-and-Descriptions.html
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index a6a383156d..8a2e0e9e84 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -18,6 +18,7 @@ 
 ;;; Copyright © 2021 Antero Mejr <antero@kodmin.com>
 ;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -37525,6 +37526,35 @@  text-buffer for applications such as text editors.  Ropey is fast, robust, and
 can handle huge texts and memory-incoherent edits with ease.")
     (license license:expat)))

+(define-public rust-rot8-0.1
+  (package
+    (name "rust-rot8")
+    (version "0.1.3")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (crate-uri "rot8" version))
+        (file-name
+          (string-append name "-" version ".tar.gz"))
+        (sha256
+          (base32
+            "15mhszk9qy2q49dpab4p0d9d4aph61yshaxjf02mhdx07n9qpnmh"))))
+    (build-system cargo-build-system)
+    (arguments
+      `(#:cargo-inputs
+        (("rust-clap" ,rust-clap-2)
+         ("rust-glob" ,rust-glob-0.3)
+         ("rust-regex" ,rust-regex-1)
+         ("rust-serde" ,rust-serde-1)
+         ("rust-serde-json" ,rust-serde-json-1))))
+    (home-page "https://github.com/efernau/rot8")
+    (synopsis
+      "Screen rotation daemon")
+    (description
+      "Automatic rotation for modern Linux screen and input device.  Compatible
+with wayland and X11.  Uses built-in accelerometer with configurable threshold.")
+    (license license:expat)))
+
 (define-public rust-route-recognizer-0.2
   (package
     (name "rust-route-recognizer")