diff mbox series

[bug#64109,2/2] gnu: dpf-plugins: Add native-search-paths.

Message ID IRZ1QJ8FIAyqUgh88pI615_Og6BoUUq2cvWJZh3nXRpUfAcGQs9oOBJAbec1NPSRTeeNo0cdO0UB77VP9FaWEgead8FPbhTlMr7_YPogyxc=@proton.me
State New
Headers show
Series [bug#64109,1/2] gnu: dpf-plugins: Update to 1.7. | expand

Commit Message

Sughosha June 16, 2023, 2:46 p.m. UTC
From a74eb4c58d45d30450ba8b70e4faddee52b37f13 Mon Sep 17 00:00:00 2001
Message-Id: <a74eb4c58d45d30450ba8b70e4faddee52b37f13.1686926462.git.sughosha@proton.me>
In-Reply-To: <23da89c3cbf2358ac70d387ebd714abe03b6758e.1686926462.git.sughosha@proton.me>
References: <23da89c3cbf2358ac70d387ebd714abe03b6758e.1686926462.git.sughosha@proton.me>
From: Sughosha <sughosha@proton.me>
Date: Fri, 16 Jun 2023 16:39:21 +0200
Subject: [PATCH 2/2] gnu: dpf-plugins: Add native-search-paths.

* gnu/packages/music.scm (dpf-plugins): Add native-search-paths.
---
 gnu/packages/music.scm | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)

Comments

Ludovic Courtès Sept. 14, 2023, 9:05 p.m. UTC | #1
Hi,

I applied the first patch (upgrade).

Sughosha <Sughosha@proton.me> skribis:

>>From a74eb4c58d45d30450ba8b70e4faddee52b37f13 Mon Sep 17 00:00:00 2001
> Message-Id: <a74eb4c58d45d30450ba8b70e4faddee52b37f13.1686926462.git.sughosha@proton.me>
> In-Reply-To: <23da89c3cbf2358ac70d387ebd714abe03b6758e.1686926462.git.sughosha@proton.me>
> References: <23da89c3cbf2358ac70d387ebd714abe03b6758e.1686926462.git.sughosha@proton.me>
> From: Sughosha <sughosha@proton.me>
> Date: Fri, 16 Jun 2023 16:39:21 +0200
> Subject: [PATCH 2/2] gnu: dpf-plugins: Add native-search-paths.
>
> * gnu/packages/music.scm (dpf-plugins): Add native-search-paths.

[...]

> @@ -6372,6 +6372,25 @@ (define-public dpf-plugins
>             liblo ; for dssi plugins
>             jack-1 ; for standalone applications
>             mesa))
> +    (native-search-paths
> +     (list (search-path-specification
> +            (variable "CLAP_PATH")
> +            (files '("lib/clap")))
> +           (search-path-specification
> +            (variable "DSSI_PATH")
> +            (files '("lib/dssi")))
> +           (search-path-specification
> +            (variable "LADSPA_PATH")
> +            (files '("lib/ladspa")))
> +           (search-path-specification
> +            (variable "LV2_PATH")
> +            (files '("lib/lv2")))
> +           (search-path-specification
> +            (variable "VST2_PATH")
> +            (files '("lib/vst")))
> +           (search-path-specification
> +            (variable "VST3_PATH")
> +            (files '("lib/vst3")))))

At first sight I think this is incorrect: search paths should be
specified in the patch that honors them.  See
<https://guix.gnu.org/manual/devel/en/html_node/Search-Paths.html>.

Am I right that ‘dnf-plugins’ does not honor them, but instead ‘ladspa’
(maybe?) does?  (I’m no expert here.)

Ludo’.
Thorsten Wilms Sept. 15, 2023, 7:35 a.m. UTC | #2
On Thu, 14 Sep 2023 23:05:40 +0200
Ludovic Courtès <ludo@gnu.org> wrote:

> At first sight I think this is incorrect: search paths should be
> specified in the patch that honors them.  See
> <https://guix.gnu.org/manual/devel/en/html_node/Search-Paths.html>.
> 
> Am I right that ‘dnf-plugins’ does not honor them, but instead ‘ladspa’
> (maybe?) does?  (I’m no expert here.)

Plugins definitively don’t need the search paths. Seeing how ardour is
defined without, it must mean even hosts don’t need them, only the
relevant libraries must have them. audio.scm seems to be sprinkled
with unnecessary search path definitions, aiding in the ongoing
confusion.
diff mbox series

Patch

diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index c767da803f..3498cad887 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -6372,6 +6372,25 @@  (define-public dpf-plugins
            liblo ; for dssi plugins
            jack-1 ; for standalone applications
            mesa))
+    (native-search-paths
+     (list (search-path-specification
+            (variable "CLAP_PATH")
+            (files '("lib/clap")))
+           (search-path-specification
+            (variable "DSSI_PATH")
+            (files '("lib/dssi")))
+           (search-path-specification
+            (variable "LADSPA_PATH")
+            (files '("lib/ladspa")))
+           (search-path-specification
+            (variable "LV2_PATH")
+            (files '("lib/lv2")))
+           (search-path-specification
+            (variable "VST2_PATH")
+            (files '("lib/vst")))
+           (search-path-specification
+            (variable "VST3_PATH")
+            (files '("lib/vst3")))))
     (native-inputs
      (list pkg-config dssi lv2))
     (home-page "https://github.com/DISTRHO/DPF-Plugins")