diff mbox series

[bug#53707] Fix bad substitution in Elixir recipe

Message ID HcPAHj0lMs-lzPfM1-l9nqLh5c09NRtoqdJPmiZgTJgmFCy-u0MaTK-Qel-z9nHcxF4gdR64FqwugE9Xd4OGj4mp-CMr8hpzv77PCvlbE1U=@evrl.com
State Accepted
Headers show
Series [bug#53707] Fix bad substitution in Elixir recipe | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Cees de Groot Feb. 1, 2022, 6:32 p.m. UTC
From d8148d5bb2d17f96c1a8034b1854f2b9f890e37a Mon Sep 17 00:00:00 2001
From: Cees de Groot <cg@evrl.com>
Date: Tue, 1 Feb 2022 13:29:33 -0500
Subject: [PATCH] Fix /bin/sh replacement for Elixir

I have no clue where this went wrong, but substituting "sh" instead of "/bin/sh" was bound to fail. Maybe something upstream changed? In any case, this should be more correct.

---
 gnu/packages/elixir.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

--
2.34.0

Comments

Maxim Cournoyer Feb. 24, 2022, 3:01 a.m. UTC | #1
Hi,

Cees de Groot <cg@evrl.com> writes:

>>From d8148d5bb2d17f96c1a8034b1854f2b9f890e37a Mon Sep 17 00:00:00 2001
> From: Cees de Groot <cg@evrl.com>
> Date: Tue, 1 Feb 2022 13:29:33 -0500
> Subject: [PATCH] Fix /bin/sh replacement for Elixir
>
> I have no clue where this went wrong, but substituting "sh" instead of "/bin/sh" was bound to fail. Maybe something upstream changed? In any case, this should be more correct.
>
> ---
>  gnu/packages/elixir.scm | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/gnu/packages/elixir.scm b/gnu/packages/elixir.scm
> index 3fb74a56a5..fae8279e5c 100644
> --- a/gnu/packages/elixir.scm
> +++ b/gnu/packages/elixir.scm
> @@ -68,7 +68,7 @@ (define-public elixir
>                (substitute* '("lib/mix/lib/mix/release.ex"
>                               "lib/mix/lib/mix/tasks/release.init.ex")
>                  (("#!/bin/sh")
> -                 (string-append "#!" (search-input-file inputs "sh"))))
> +                 (string-append "#!" (search-input-file inputs "/bin/sh"))))
>                (substitute* "bin/elixir"
>                  (("^ERTS_BIN=$")
>                   (string-append
> --
> 2.34.0

This has already been fixed by Ludovic in commit
d5353e24700102eb3fbf872800135b13e0268ea1.

Closing.

Maxim
diff mbox series

Patch

diff --git a/gnu/packages/elixir.scm b/gnu/packages/elixir.scm
index 3fb74a56a5..fae8279e5c 100644
--- a/gnu/packages/elixir.scm
+++ b/gnu/packages/elixir.scm
@@ -68,7 +68,7 @@  (define-public elixir
               (substitute* '("lib/mix/lib/mix/release.ex"
                              "lib/mix/lib/mix/tasks/release.init.ex")
                 (("#!/bin/sh")
-                 (string-append "#!" (search-input-file inputs "sh"))))
+                 (string-append "#!" (search-input-file inputs "/bin/sh"))))
               (substitute* "bin/elixir"
                 (("^ERTS_BIN=$")
                  (string-append