diff mbox series

[bug#59938] add python-ogr2osm package

Message ID HbqTcyLwnJjyy9QxUa6NnAxIoGt17jb-kDNzcf54Hw8n2-w02xfhJgX4bqpIK76APq07PlFpGC5iasvvVbrChU4ATli3OPfVKgkhTlkCijM=@patricknoll.com
State New
Headers show
Series [bug#59938] add python-ogr2osm package | expand

Commit Message

Patrick Noll Dec. 10, 2022, 4:37 a.m. UTC
gnu/packages/geo.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)


base-commit: 3ae6f30767f962da74d18d824b521462e149b89a
-- 2.38.1

Comments

Nicolas Goaziou April 23, 2023, 2:47 p.m. UTC | #1
Hello,

Patrick Noll <patrick@patricknoll.com> writes:

> +(define-public python-ogr2osm

Thank you.

Please note your commit message is not properly formatted. It should
look like:

    gnu: Add python-ogr2osm.

    * gnu/packages/geo.scm (python-ogr2osm): New variable.

Also, indentation is a bit off. You may want to use "guix style" command
to format the packge.

> + (propagated-inputs
> + (list python-gdal python-lxml))

AFAIK, python-gdal is not provided in Guix, so you would need to package
it as well. Also, the package itself probably requires gdal as an input.

> + (arguments '(#:tests? #f)) ; Tests not included in release tarball

Maybe it is better to get it from upsteram them. WDYT?

> + (home-page
> + "https://github.com/roelderickx/ogr2osm")
> + (synopsis
> + "Convert ogr-readable files like shapefiles into Openstreetmap(osm) format")
> + (description
> + "A tool for converting ogr-readable files into Openstreetmap(osm)
> format. Ogr2osm supports reading from ogr files like shapefiles or
> Postgres database. Ogr2osm converts data into osm or osm.pbf formats.
> A translation file can be used to manipulate the data during
> conversion.")

The description should consist of complete sentences. Also, sentences
need to be separated with two spaces.

Would you want to send an updated patch?

Regards,
Sharlatan Hellseher Jan. 26, 2024, 1:26 a.m. UTC | #2
Hi Nicolas and Patrick,

I've applied all suggestions mentioned re-style the package, enable simple
tests, update to the latest upstream version and tested if after build.

Please let me know if it's good now.

Thanks,
Oleg

Patrick Noll (1):
  gnu: Add python-ogr2osm.

 gnu/packages/geo.scm | 59 +++++++++++++++++++++++++++++++++++++++++++-
 1 file changed, 58 insertions(+), 1 deletion(-)


base-commit: fdffaa2256775a48585dbc563d646fdccb96f284
Sharlatan Hellseher Jan. 28, 2024, 10:33 p.m. UTC | #3
Pushed as 7bf6a6f9db23980d2e2508842dcb303a9910b839 to master.

Thanks,
Oleg
diff mbox series

Patch

diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index b3a5c0df3f..cbe88bf9bc 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -770,6 +770,29 @@  (define-public python-geopandas
require a spatial database such as PostGIS.")
(license license:bsd-3)))

+(define-public python-ogr2osm
+ (package
+ (name "python-ogr2osm")
+ (version "1.1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "ogr2osm" version))
+ (sha256
+ (base32
+ "1rs0qjahssikayn91n790ms8dj3m3v327hp03c9ivlzn8vg6kalf"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ (list python-gdal python-lxml))
+ (arguments '(#:tests? #f)) ; Tests not included in release tarball
+ (home-page
+ "https://github.com/roelderickx/ogr2osm")
+ (synopsis
+ "Convert ogr-readable files like shapefiles into Openstreetmap(osm) format")
+ (description
+ "A tool for converting ogr-readable files into Openstreetmap(osm) format. Ogr2osm supports reading from ogr files like shapefiles or Postgres database. Ogr2osm converts data into osm or osm.pbf formats. A translation file can be used to manipulate the data during conversion.")
+ (license license:expat))
+
(define-public python-osmnx
(package
(name "python-osmnx")