diff mbox series

[bug#60316] WIP: Add homeassistant.

Message ID GbwhtL97GyJGV2-KL-uY0aKQINkXGFRmj1MoeO25f5LnR_Fbg-dW2SH6kkGyqOhaPinfulGyzIn0dHbcFXPolDRvoJynfrPihIEQGYnuQxY=@protonmail.com
State New
Headers show
Series [bug#60316] WIP: Add homeassistant. | expand

Commit Message

phodina Dec. 27, 2022, 10:06 p.m. UTC
>> > I'd love to add Home assistant to Guix to liberate our homes :-D
> 
> 
> Woah! Thanks so much for working on this. I've been eyeing at
> homeassitant for a while. :D
> 
> > However, it has one nasty problem. There's one Python module 'orjson' which depends on rust package [1]. Since it would mean to add a lot of Rust packages I'd like to ask for help if there isn't a better way to build the package 'orjson'?
> 
> 
> I'd like to help. Let's see if we can avoid that dependency. If we
> can't, I'll aid this work with packing the related rust packages.

Here are the additional Python packages from the orjson module repo from various requirements.txt.
Please consider them more WIP as they build and allow you to have a look around the 'python-orjson'.
I also have the Rust modules, but packaging them is quite tedious as it's almost 3k lines of code :-/
Any ideas here?

> 
> > Just out of curiosity have you been able to package the Home assistant?
> 
> 
> Darn! I forgot that I created that post. I must've working on that and
> lost the work because of SSD failure happened midst 2021. :(

Home the 'smartmontools' might save you from similar thing in future :-)

----
Petr

Comments

phodina Jan. 14, 2023, 7:54 p.m. UTC | #1
Hi Raghav,

have you had the time to check the Rust dependencies for the Python module `orjson`?

Kind regards
Petr
Raghav Gururajan Jan. 16, 2023, 3:53 a.m. UTC | #2
Petr,

> have you had the time to check the Rust dependencies for the Python module `orjson`?

Not yet, unfortunately.

I'll be working on the 21st and 22nd of this month. I'll let you know.

Regards,
RG.
diff mbox series

Patch

From 1898eda096589690a29f77679ae313701ee6ea4a Mon Sep 17 00:00:00 2001
From: Petr Hodina <phodina@protonmail.com>
Date: Tue, 27 Dec 2022 23:00:34 +0100
Subject: [PATCH 08/10] gnu: Add python-types-simplejson.

* gnu/packages/python-xyz.scm (python-types-simplejson): New variable.

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 48044a3ef3..91af772a4f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -30604,6 +30604,22 @@  (define-public python-types-pytz
 collection.")
     (license license:asl2.0)))
 
+(define-public python-types-simplejson
+  (package
+    (name "python-types-simplejson")
+    (version "3.18.0.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "types-simplejson" version))
+              (sha256
+               (base32
+                "0lizf6aiiphvd3l02gk6qm16i6p7a98rdgh3s786bg8a349xnyl5"))))
+    (build-system python-build-system)
+    (home-page "https://github.com/python/typeshed")
+    (synopsis "Typing stubs for simplejson")
+    (description "Typing stubs for simplejson")
+    (license license:asl2.0)))
+
 (define-public python-types-toml
   (package
     (name "python-types-toml")
-- 
2.38.1