diff mbox series

[bug#49345] Add CL-Hunchenissr-Routes and Its Dependencies

Message ID GClskDkPBZ8tUWneiYv6Rq15VNHpVCc53cRs0w1yeoBwdZtKYcXBc4XQvuCgSw9N0dZp-Pr8rAk3JJOxoFdg8tI1OapmCLf1edqKW90qEXU=@protonmail.com
State Accepted
Headers show
Series [bug#49345] Add CL-Hunchenissr-Routes and Its Dependencies | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Charles July 3, 2021, 3:12 a.m. UTC
Just let me know if this is to big of a change for an email or if anything else is wrong with it.

Comments

Guillaume Le Vaillant July 3, 2021, 12:39 p.m. UTC | #1
Charles via Guix-patches via <guix-patches@gnu.org> skribis:

> Just let me know if this is to big of a change for an email or if anything else is wrong with it.

Having many patches attached to an email is not a problem. However all
your patches have the same "0001" prefix, it would be better if the
prefixes had the right number indicating in which order the patches must
be applied (although in this case it was not hard to find out).

I pushed cl-unification, cl-trivial-with-current-source-form, cl-tailrec
and cl-issr-core with a few modifications as
e2e17903fbb726467d74d8da367f51fa0206a12b and following.

However cl-hunchenissr requires the cl-portal package which is
apparently missing from your patches.

Could you send updated patches for cl-portal, cl-hunchenissr and
cl-hunchenissr-routes?
diff mbox series

Patch

From 73097c34e763ba576a8fce21b1c09a67a91aa072 Mon Sep 17 00:00:00 2001
From: Charles <charles.b.jackson@protonmail.com>
Date: Sat, 26 Jun 2021 09:50:35 -0500
Subject: [PATCH] gnu: Add cl-unification.

* gnu/packages/lisp-xyz.scm (sbcl-unification): Add new variable.
* gnu/packages/lisp-xyz.scm (ecl-unification): Add new variable.
* gnu/packages/lisp-xyz.scm (cl-unification): Add new variable.
---
 gnu/packages/lisp-xyz.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)

diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index f8aae805ed..ef5e445d7d 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -9890,6 +9890,36 @@  correctly.")
 (define-public ecl-trivialib-type-unify
   (sbcl-package->ecl-package sbcl-trivialib-type-unify))
 
+(define-public sbcl-cl-unification
+  (package
+    (name "sbcl-cl-unification")
+    (version "20200820")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://gitlab.common-lisp.net/cl-unification/cl-unification")
+             (commit "01079f34d197495880aa49ab727d63774d83035c")))
+       (file-name (git-file-name "cl-unification" version))
+       (sha256
+        (base32 "0nhqamn3qgg38i6aw2pshffdwr2hzslycg8ficmn333gw0h9rf4g"))))
+    (build-system asdf-build-system/sbcl)
+    (inputs
+     `(("sbcl-ptester" ,sbcl-ptester)))
+    (home-page "http://common-lisp.net/project/cl-unification")
+    (synopsis "Provide a full blown unification framework for Common Lisp")
+    (description "Unify arbitrary Common Lisp objects while constructing
+bindings for placeholders (unification variables) in a template
+sublanguage. Unify two objects with a simmilar shape, one having some
+unification variables to resolve (unify) the values of the variables.")
+    (license license:bsd-0)))
+
+(define-public ecl-cl-unification
+  (sbcl-package->ecl-package sbcl-cl-unification))
+
+(define-public cl-unification
+  (sbcl-package->cl-source-package sbcl-cl-unification))
+
 (define-public sbcl-specialized-function
   (let ((commit "5e2b04432bdf728496e6ff7227f210f845af7247")
         (revision "3"))
-- 
2.32.0