diff mbox series

[bug#53418] gnu: piper: Fix build.

Message ID FxvM2_cQc3tj3fX9k59Bo8WQL2VV3aUiRzP34Yt44c6d1VcvE2sENtUYDB48LMb1KonKiCADpVS5VwoHNua2pqEpcLS-dcRx9I5RT3yEz5Q=@protonmail.com
State Accepted
Headers show
Series [bug#53418] gnu: piper: Fix build. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

John Kehayias Jan. 21, 2022, 6:17 p.m. UTC
Hello,

This is a followup to https://issues.guix.gnu.org/53372  fixing Piper (which uses libratbag). Python was added to the inputs to fix the build since Meson does not propagate Python (added to inputs rather than native-inputs as guix gc shows a reference to Python).

That allows Piper to build but it had a librsvg error on startup, like syncthing-gtk in https://issues.guix.gnu.org/52651  Fixed the same way here by removing librsvg from inputs since it is propagated by gtk+.

(Also simplified the input labels while I was at it, but my quick attempt at rewriting the phases with gexps didn't get far. Since I didn't find any similar examples in current packages, I left it as is for now.)

Thanks!
John

Comments

Leo Famulari Jan. 21, 2022, 6:26 p.m. UTC | #1
On Fri, Jan 21, 2022 at 06:17:57PM +0000, John Kehayias via Guix-patches via wrote:
> Hello,
> 
> This is a followup to https://issues.guix.gnu.org/53372  fixing Piper (which uses libratbag). Python was added to the inputs to fix the build since Meson does not propagate Python (added to inputs rather than native-inputs as guix gc shows a reference to Python).
> 
> That allows Piper to build but it had a librsvg error on startup, like syncthing-gtk in https://issues.guix.gnu.org/52651  Fixed the same way here by removing librsvg from inputs since it is propagated by gtk+.
> 
> (Also simplified the input labels while I was at it, but my quick attempt at rewriting the phases with gexps didn't get far. Since I didn't find any similar examples in current packages, I left it as is for now.)
> 
> Thanks!
> John

> From 5ae7945017dc4d664bdc6ddbffaea6422db72402 Mon Sep 17 00:00:00 2001
> From: John Kehayias <john.kehayias@protonmail.com>
> Date: Fri, 21 Jan 2022 13:05:15 -0500
> Subject: [PATCH] gnu: piper: Fix build.
> 
> Since commit 6f36d0c89e3bf19bb7bb8f7f5b77de30c9af861b, Meson no longer
> propagates Python.  GTK+ propagates librsvg-bootstrap which causes a startup
> error due to two librsvg being GI_TYPELIB_PATH.
> 
> * gnu/packages/gnome.scm (piper)[inputs]: Add PYTHON.  Remove LIBRSVG.  Simplify.
> [native-inputs]: Simplify.
> [arguments]: Remove trailing #t from phases.

Thanks! Pushed as 0baf5efe01d613f82edca39b47ef2126803127a4
diff mbox series

Patch

From 5ae7945017dc4d664bdc6ddbffaea6422db72402 Mon Sep 17 00:00:00 2001
From: John Kehayias <john.kehayias@protonmail.com>
Date: Fri, 21 Jan 2022 13:05:15 -0500
Subject: [PATCH] gnu: piper: Fix build.

Since commit 6f36d0c89e3bf19bb7bb8f7f5b77de30c9af861b, Meson no longer
propagates Python.  GTK+ propagates librsvg-bootstrap which causes a startup
error due to two librsvg being GI_TYPELIB_PATH.

* gnu/packages/gnome.scm (piper)[inputs]: Add PYTHON.  Remove LIBRSVG.  Simplify.
[native-inputs]: Simplify.
[arguments]: Remove trailing #t from phases.
---
 gnu/packages/gnome.scm | 35 +++++++++++++++++------------------
 1 file changed, 17 insertions(+), 18 deletions(-)

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 088c368054..565e3987b7 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -67,6 +67,7 @@ 
 ;;; Copyright © 2021 Mathieu Othacehe <othacehe@gnu.org>
 ;;; Copyright © 2022 Daniel Meißner <daniel.meissner-i4k@ruhr-uni-bochum.de>
 ;;; Copyright © 2022 Pierre Langlois <pierre.langlois@gmx.com>
+;;; Copyright © 2022 John Kehayias <john.kehayias@protonmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -12101,21 +12102,21 @@  (define-public piper
        (file-name (git-file-name name version))))
     (build-system meson-build-system)
     (native-inputs
-     `(("gettext" ,gettext-minimal)
-       ("glib:bin" ,glib "bin")
-       ("gobject-introspection" ,gobject-introspection)
-       ("pkg-config" ,pkg-config)
-       ("python-flake8" ,python-flake8)))
+     (list gettext-minimal
+           `(,glib "bin")
+           gobject-introspection
+           pkg-config
+           python-flake8))
     (inputs
-     `(("adwaita-icon-theme" ,adwaita-icon-theme)
-       ("gtk" ,gtk+)
-       ("gtk:bin" ,gtk+ "bin")
-       ("libratbag" ,libratbag)
-       ("librsvg" ,librsvg)
-       ("python-evdev" ,python-evdev)
-       ("python-lxml" ,python-lxml)
-       ("python-pycairo" ,python-pycairo)
-       ("python-pygobject" ,python-pygobject)))
+     (list adwaita-icon-theme
+           gtk+
+           `(,gtk+ "bin")
+           libratbag
+           python
+           python-evdev
+           python-lxml
+           python-pycairo
+           python-pygobject))
     (arguments
      `(#:imported-modules ((guix build python-build-system)
                            ,@%meson-build-system-modules)
@@ -12128,8 +12129,7 @@  (define-public piper
          (add-after 'unpack 'dont-update-gtk-icon-cache
            (lambda _
              (substitute* "meson.build"
-               (("meson.add_install_script('meson_install.sh')") ""))
-             #t))
+               (("meson.add_install_script('meson_install.sh')") ""))))
          ;; TODO: Switch to wrap-script when it is fixed.
          (add-after 'install 'wrap-python
            (assoc-ref python:%standard-phases 'wrap))
@@ -12137,8 +12137,7 @@  (define-public piper
            (lambda* (#:key outputs #:allow-other-keys)
              (wrap-program
                  (string-append (assoc-ref outputs "out" )"/bin/piper")
-               `("GI_TYPELIB_PATH" = (,(getenv "GI_TYPELIB_PATH"))))
-             #t)))))
+               `("GI_TYPELIB_PATH" = (,(getenv "GI_TYPELIB_PATH")))))))))
     (home-page "https://github.com/libratbag/piper/")
     (synopsis "Configure bindings and LEDs on gaming mice")
     (description "Piper is a GTK+ application for configuring gaming mice with
-- 
2.34.0