diff mbox series

[bug#47402] gnu: Add emacs-sdcv

Message ID Fm5We2Wu-muqRnOwFgu3LuRa5F1pXOE3B2IbUVOO7ohhw_r_ccsAuf3WYjqa-bVEhzXETi9gc91rOPsuwzamXLFn8UnkqSiVzlfB_Bcr-9Y=@protonmail.com
State Accepted
Headers show
Series [bug#47402] gnu: Add emacs-sdcv | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

qblade March 26, 2021, 6:18 a.m. UTC
I submitted two patches, emacs-showtip is a dependency of emacs-sdcv.

Comments

Nicolas Goaziou March 26, 2021, 2:03 p.m. UTC | #1
Hello,

qblade via Guix-patches via <guix-patches@gnu.org> writes:

> I submitted two patches, emacs-showtip is a dependency of emacs-sdcv.

Thank you. Some comments follow.

> +(define-public emacs-showtip
> +  (package
> +    (name "emacs-showtip")
> +    (version "20090830.1040")

This is not the correct version number. Main file indicates "0.01".

> +    (source
> +     (origin
> +       (method git-fetch)
> +       (uri (git-reference
> +             (url "https://github.com/emacsorphanage/showtip")
> +             (commit
> +              "930da302809a4257e8d69425455b29e1cc91949b")))
> +       (file-name (git-file-name name version))
> +       (sha256
> +        (base32
> +         "01zak0zhha6dp7a2hm28d065gjnc462iwpsfyxhbxgfzcdlicqc7"))))
> +    (build-system emacs-build-system)
> +    (home-page "https://github.com/emacsorphanage/showtip")
> +    (synopsis "Show tip at cursor")
> +    (description
> +     "This library export one function for elisp programer to show
> +tooltip near the cursor not the mouse.")

export -> exports or even, provides

I would also drop the "for Elisp programmer" part.

> +(define-public emacs-sdcv
> +  (package
> +    (name "emacs-sdcv")
> +    (version "20190610.732")

The correct version number seems to be 1.5.2 on the GitHub repository,
and 2.9 on emacswiki. However, using Emacswiki as a source is not an
option, since there is no archival for outdated releases there, AFAICT.

Are we stuck with an old release?

> +    (source
> +     (origin
> +       (method git-fetch)
> +       (uri (git-reference
> +             (url "https://github.com/stardiviner/sdcv.el")
> +             (commit
> +              "943ae3e90cc9a0a88a37cc710acd7424fd4defc4")))

Since you're targetting a specific commit, you need to add a commit and
a revision binding at the top of the definition. See, e.g.,
emacs-vterm-toggle.

> +       (file-name (git-file-name name version))
> +       (sha256
> +        (base32
> +         "0i1ylvw7p46pkf3yyyzcdmdhsspzymnnnvx8s0i7vynngr5x0vzh"))))
> +    (build-system emacs-build-system)
> +    (propagated-inputs
> +     `(("emacs-popup" ,emacs-popup)
> +       ("emacs-showtip" ,emacs-showtip)
> +       ("emacs-pos-tip" ,emacs-pos-tip)))
> +    (home-page
> +     "https://www.emacswiki.org/emacs/download/sdcv.el")
> +    (synopsis
> +     "Emacs interface for sdcv")

Could you explain quickly what SDCV is in the synopsis?

> +    (description
> +     "Translate word by sdcv (console version of Stardict), and display
> +translation use popup tooltip or buffer.")

The description needs to consist of full sentences.


Could you send updated patches?

Regards,
diff mbox series

Patch

From 257b3463c7a1a4b35768bf8070d69ebe133b1ae5 Mon Sep 17 00:00:00 2001
From: qblade <qblade@protonmail.com>
Date: Fri, 26 Mar 2021 01:18:23 +0000
Subject: [PATCH 2/2] gnu: Add emacs-sdcv

* gnu/packages/emacs-xyz.scm (emacs-sdcv): New variable.
---
 gnu/packages/emacs-xyz.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index bf3cac7b44..5b7ce93a27 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -27374,3 +27374,32 @@  shorter than usual, using mostly unprefixed keys.")
      "This library export one function for elisp programer to show
 tooltip near the cursor not the mouse.")
     (license license:gpl2+)))
+
+(define-public emacs-sdcv
+  (package
+    (name "emacs-sdcv")
+    (version "20190610.732")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/stardiviner/sdcv.el")
+             (commit
+              "943ae3e90cc9a0a88a37cc710acd7424fd4defc4")))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "0i1ylvw7p46pkf3yyyzcdmdhsspzymnnnvx8s0i7vynngr5x0vzh"))))
+    (build-system emacs-build-system)
+    (propagated-inputs
+     `(("emacs-popup" ,emacs-popup)
+       ("emacs-showtip" ,emacs-showtip)
+       ("emacs-pos-tip" ,emacs-pos-tip)))
+    (home-page
+     "https://www.emacswiki.org/emacs/download/sdcv.el")
+    (synopsis
+     "Emacs interface for sdcv")
+    (description
+     "Translate word by sdcv (console version of Stardict), and display
+translation use popup tooltip or buffer.")
+    (license license:gpl3+)))
-- 
2.31.0