diff mbox series

[bug#57702,v2,1/8] gnu: Add rust-unic-emoji-char-0.9.

Message ID FenAi_5pg_vMq0RrJ-v18am-Bk82cm5qaagQSJ9qskEzq1pRd7BWqN7tGxN0vf09H6zqo5XSq8kQCzJnVqiQ-HQ4qDzSIHNYOjdfdu1Zqdg=@protonmail.com
State New
Headers show
Series Update rust-clap-3 to 3.2.17 | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

VesselWave Sept. 9, 2022, 4:03 p.m. UTC
---
gnu/packages/crates-io.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

--2.37.2

Comments

\( Sept. 9, 2022, 8:30 p.m. UTC | #1
Hi VesselWave,

On Fri Sep 9, 2022 at 5:03 PM BST, VesselWave via Guix-patches via wrote:
> +(define-public rust-unic-emoji-char-0.9
> + (package
> + (name "rust-unic-emoji-char")
> + (version "0.9.0")
> + (source (origin
> + (method url-fetch)
> + (uri (crate-uri "unic-emoji-char" version))
> + (file-name (string-append name "-" version ".tar.gz"))
> + (sha256
> + (base32
> + "0ka9fr7s6lv0z43r9xphg9injn35pfxf9g9q18ki0wl9d0g241qb"))))
> + (build-system cargo-build-system)
> + (arguments
> + `(#:skip-build? #t
> + #:cargo-inputs (("rust-unic-property-char" ,rust-unic-char-property-0.9)
> + ("rust-unic-char-range" ,rust-unic-char-range-0.9)
> + ("rust-unic-ucd-version" ,rust-unic-ucd-version-0.9))))
> + (home-page "https://github.com/open-i18n/rust-unic/")
> + (synopsis "Emoji character properties for UNIC")
> + (description "This package provides emoji character properties and for
> +the Unicode and Internationalization Crates (UNIC) project.")
> + (license (list license:expat license:asl2.0))))

That's some... interesting indentation you've got going on there :)
Could you please change this patchset to match the project standard
like this?

> +(define-public rust-unic-emoji-char-0.9
> +  (package
> +    (name "rust-unic-emoji-char")
> +    (version "0.9.0")
> +    (source (origin
> +              (method url-fetch)
> +              (uri (crate-uri "unic-emoji-char" version))
> +              (file-name (string-append name "-" version ".tar.gz"))
> +              (sha256
> +               (base32
> +                "0ka9fr7s6lv0z43r9xphg9injn35pfxf9g9q18ki0wl9d0g241qb"))))
> +    (build-system cargo-build-system)
> +    (arguments
> +     (list #:skip-build? #t
         ^^^^ note change of `(...) to (list ...), which is now the standard
> +           #:cargo-inputs `(("rust-unic-property-char" ,rust-unic-char-property-0.9)
                             ^ note the quoting of cargo-inputs, due to the change
                             ^ to (list ...)
> +                            ("rust-unic-char-range" ,rust-unic-char-range-0.9)
> +                            ("rust-unic-ucd-version" ,rust-unic-ucd-version-0.9))))
> +    (home-page "https://github.com/open-i18n/rust-unic")
> +    (synopsis "Emoji character properties for UNIC")
> +    (description
> +     "This package provides emoji character properties and for
> +the Unicode and Internationalization Crates (UNIC) project.")
> +    (license (list license:expat license:asl2.0))))

    -- (
\( Sept. 9, 2022, 8:33 p.m. UTC | #2
Hmm, now that I look closer, it appears to be affecting even packages that
existed previously, so maybe it's your email client hijacking the formatting?

    -- (
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 02f7bc7d4d..a82515f73e 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -69234,6 +69234,29 @@  (define-public rust-unic-common-0.9
Internationalization Crates (UNIC) project.")
(license (list license:expat license:asl2.0))))

+(define-public rust-unic-emoji-char-0.9
+ (package
+ (name "rust-unic-emoji-char")
+ (version "0.9.0")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "unic-emoji-char" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0ka9fr7s6lv0z43r9xphg9injn35pfxf9g9q18ki0wl9d0g241qb"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs (("rust-unic-property-char" ,rust-unic-char-property-0.9)
+ ("rust-unic-char-range" ,rust-unic-char-range-0.9)
+ ("rust-unic-ucd-version" ,rust-unic-ucd-version-0.9))))
+ (home-page "https://github.com/open-i18n/rust-unic/")
+ (synopsis "Emoji character properties for UNIC")
+ (description "This package provides emoji character properties and for
+the Unicode and Internationalization Crates (UNIC) project.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-unic-segment-0.9
(package
(name "rust-unic-segment")