diff mbox series

[bug#44814] gnu: Add oauth2l.

Message ID FTBLTXXQ70.3V74YN1YD0339@wilsonb.com
State Accepted
Headers show
Series [bug#44814] gnu: Add oauth2l. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Deslauriers, Douglas via Guix-patches" via Nov. 23, 2020, 8:45 a.m. UTC

diff mbox series

Patch

From 4cb46d71c90ad1db379ad18731e9b07923d8f696 Mon Sep 17 00:00:00 2001
From: "B. Wilson" <elaexuotee@wilsonb.com>
Date: Mon, 23 Nov 2020 17:39:38 +0900
Subject: [PATCH] gnu: Add oauth2l.
To: guix-patches@gnu.org

gnu/packages/authentication.scm (oauth2l): New variable.
---
 gnu/packages/authentication.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)

diff --git a/gnu/packages/authentication.scm b/gnu/packages/authentication.scm
index afa20945e7..f8a6fdf4ed 100644
--- a/gnu/packages/authentication.scm
+++ b/gnu/packages/authentication.scm
@@ -1,6 +1,7 @@ 
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2018, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2019 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2020 B. Wilson <elaexuotee@wilsonb.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -25,6 +26,7 @@ 
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages security-token)
   #:use-module (guix build-system gnu)
+  #:use-module (guix build-system go)
   #:use-module (guix download)
   #:use-module (guix git-download)
   #:use-module ((guix licenses) #:prefix license:)
@@ -115,3 +117,29 @@  and the time-based @dfn{TOTP} algorithm (RFC6238).")
       (description "The Yubico PAM module provides an easy way to integrate the
 YubiKey into your existing user authentication infrastructure.")
       (license license:bsd-2))))
+
+(define-public oauth2l
+  (package
+    (name "oauth2l")
+    (version "1.1.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/google/oauth2l")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1icgcqk15y9f16mpg243570xfrcfs0lvhn5xl18yfxkwayxffgaf"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/google/oauth2l"))
+    (home-page "https://github.com/google/oauth2l")
+    (synopsis "Simple CLI for interacting with Google API authentication")
+    (description
+     "@code{oauth2l} (pronounced ``oauth tool'') is a simple command-line tool
+for working with @url{https://developers.google.com/identity/protocols/OAuth2,
+Google OAuth 2.0} written in Go.  Its primary use is to fetch and print OAuth
+2.0 access tokens, which can be used with other command-line tools and
+scripts.")
+    (license license:asl2.0)))
-- 
2.29.2