diff mbox series

[bug#50661,v3] gnu: Add valeronoi.

Message ID FFUI6LHF_Ifa_LxK0vmjOqIKdXlA5tJfWfiXvr2iQC0s7K7dWvH2Wf_iVQMKHkLllpYkkivs_sBbVvETKAjgVaQ2sRn2R-y2erUtWwreywQ=@protonmail.com
State Accepted
Headers show
Series [bug#50661,v3] gnu: Add valeronoi. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

phodina Sept. 27, 2021, 10:52 p.m. UTC
* gnu/packages/engineering.scm (valeronoi): New variable.

--
2.32.0

Comments

phodina Dec. 3, 2021, 3:36 p.m. UTC | #1
ping
Nicolas Goaziou Dec. 3, 2021, 8:39 p.m. UTC | #2
Hello,

phodina via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/engineering.scm (valeronoi): New variable.

Applied, with the changes below:

> +  (inputs `(("qtbase" ,qtbase-5)
> +            ("qtsvg" ,qtsvg)
> +            ("openssl" ,openssl)
> +            ("libxkbcommon" ,libxkbcommon)
> +            ("cgal" ,cgal)
> +            ("gmp" ,gmp)
> +            ("mpfr" ,mpfr)
> +            ("boost" ,boost)))

I sorted inputs alphabetically.

> +  (synopsis "WiFi mapping companion app for Valetudo")

I replace "app" with "application"

Note: there is a new release. You may want to update it.

Thank you.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 46622f3a1f..9dacc6c948 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -24,6 +24,7 @@ 
 ;;; Copyright © 2021 qblade <qblade@protonmail.com>
 ;;; Copyright © 2021 Gerd Heber <gerd.heber@gmail.com>
 ;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
+;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -127,6 +128,7 @@ 
   #:use-module (gnu packages xml)
   #:use-module (gnu packages xiph)
   #:use-module (gnu packages openkinect)
+  #:use-module (gnu packages xdisorg)
   #:use-module (gnu packages xorg))

 (define-public librecad
@@ -1168,6 +1170,43 @@  educational use.  As such, there is an emphasis on capabilities that improve
 the 'showing the effect of'-style of operation.")
     (license license:gpl2+)))

+(define-public valeronoi
+(package
+  (name "valeronoi")
+  (version "0.1.4")
+  (source (origin
+            (method git-fetch)
+            (uri
+             (git-reference
+              (url "https://github.com/ccoors/Valeronoi")
+              (commit (string-append "v" version))))
+            (file-name (git-file-name name version))
+            (sha256
+             (base32
+              "1zp653bjqsyixa5j1pp9k12iqsl8dz72yyi38asxmcym1wngsjcd"))))
+  (build-system cmake-build-system)
+  (arguments
+    `(#:phases
+      (modify-phases %standard-phases
+       (replace 'check
+         (lambda* (#:key tests? #:allow-other-keys)
+           (when tests?
+             (invoke "./valeronoi-tests")))))))
+  (inputs `(("qtbase" ,qtbase-5)
+            ("qtsvg" ,qtsvg)
+            ("openssl" ,openssl)
+            ("libxkbcommon" ,libxkbcommon)
+            ("cgal" ,cgal)
+            ("gmp" ,gmp)
+            ("mpfr" ,mpfr)
+            ("boost" ,boost)))
+  (synopsis "WiFi mapping companion app for Valetudo")
+  (description "Valeronoi (Valetudo + Voronoi) is a companion for Valetudo
+for generating WiFi signal strength maps.  It visualizes them using a Voronoi
+diagram.")
+  (home-page "https://github.com/ccoors/Valeronoi")
+  (license license:gpl3+)))
+
 (define-public volk
   (package
     (name "volk")