diff mbox series

[bug#50663,02/19] gnu: Add python-pyee.

Message ID F908h1zgGnHxigNPvfWOgc8OgVgxG_4Ezz_ikPC5S1crMSPh9KH09zxDaAEPfqkvVC82JkV1vwnjgQR1bHb_mNJIiQA7PYrDe-hOhq3jxQ0=@protonmail.com
State New
Headers show
Series None | expand

Commit Message

phodina Sept. 18, 2021, 7:16 p.m. UTC
This is the second patch. I unfortunately mismanaged the numbering during rebase operation. If necessary I can send the patches again or if you wrap your head around that here's the order:

0001-gnu-Add-python-requests-futures.patch
0002-gnu-Add-python-pyee.patch
0003-gnu-Add-python-fann2.patch
0004-gnu-Add-python-padaos.patch
0005-gnu-Add-python-precise-runner.patch
0006-gnu-Add-python-petact.patch
0007-gnu-Add-python-padatious.patch
0008-gnu-Add-python-lazy.patch
0009-gnu-Add-python-pako.patch
0010-gnu-Add-python-adapt-parser.patch
0011-gnu-Add-python-msm.patch
0012-gnu-Add-python-msk.patch
0013-gnu-Add-python-lingua-franca.patch
0014-gnu-Add-python-pocketsphinx.patch
0015-gnu-Add-python-gtts.patch
0016-gnu-Add-python-mycroft-messagebus-client.patch
0017-gnu-Add-mycroft-mimic.patch
0018-gnu-Add-python-speech-recognition.patch
0019-gnu-Add-python-mycroft-core.patch

Sorry for that :-)

--8<---------------cut here---------------start------------->8---

* gnu/packages/python-xyz.scm (python-pyee): New variable.

--
2.32.0
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d108389aef..c2527e915f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -16446,6 +16446,33 @@  Record Format (DWARF).")
 (define-public python2-pyev
   (package-with-python2 python-pyev))

+(define-public python-pyee
+  (package
+    (name "python-pyee")
+    (version "8.1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "pyee" version))
+       (sha256
+        (base32
+         "0cgxbdr4zmil03wwr5fv58789i51gka8a9fxm1dgkf5xs9dwrnlj"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("python-pytest-trio" ,python-pytest-trio)
+       ("python-pytest-asyncio" ,python-pytest-asyncio)
+       ("python-pytest-runner" ,python-pytest-runner)
+       ("python-pytest" ,python-pytest)
+       ("python-mock" ,python-mock)))
+    (propagated-inputs
+     `(("python-vcversioner" ,python-vcversioner)
+       ("python-twisted" ,python-twisted)
+       ("python-trio" ,python-trio)))
+    (home-page "https://github.com/jfhbrook/pyee")
+    (synopsis "Port of node.js's EventEmitter to python")
+    (description "Provides a port of node.js's EventEmitter to python.")
+    (license license:expat)))
+
 (define-public python-imagesize
   (package
     (name "python-imagesize")