diff mbox series

[bug#52780,v3] gnu: Add python-canvasapi.

Message ID F1KrHzCSP7kdoF9C8yxeE06kA8zaKg6zm5187DH23xqsgbcynlkrxWPcJpcODUeeL4ufEH199GVEmIioD2gCkGdWLqxEbTWZdLYqmn2jhVU=@protonmail.com
State Accepted
Headers show
Series [bug#52780,v3] gnu: Add python-canvasapi. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

John Kehayias Jan. 11, 2022, 9:43 p.m. UTC
> Updated after discussion on IRC to use the GitHub source which includes tests. native-input added to run the tests, all pass.

And of course left off the copyright line from earlier, added back.

Comments

Nicolas Goaziou Jan. 12, 2022, 9:25 p.m. UTC | #1
Hello,

John Kehayias via Guix-patches via <guix-patches@gnu.org> writes:

> Subject: [PATCH] gnu: Add python-canvasapi.
>
> * gnu/packages/python-web.scm (python-canvasapi): New variable.

Applied. Thank you.

Regards,
diff mbox series

Patch

From 69c1f68741ca7be3650e87001869b82c7f2acd17 Mon Sep 17 00:00:00 2001
From: John Kehayias <john.kehayias@protonmail.com>
Date: Tue, 11 Jan 2022 16:37:59 -0500
Subject: [PATCH] gnu: Add python-canvasapi.

* gnu/packages/python-web.scm (python-canvasapi): New variable.
---
 gnu/packages/python-web.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index aaf8a57f6f..951ab10903 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -47,6 +47,7 @@ 
 ;;; Copyright © 2021 Arun Isaac <arunisaac@systemreboot.net>
 ;;; Copyright © 2021 jgart <jgart@dismail.de>
 ;;; Copyright © 2021 Alice Brenon <alice.brenon@ens-lyon.fr>
+;;; Copyright © 2022 John Kehayias <john.kehayias@protonmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -4264,6 +4265,30 @@  (define-public python-yarl
 for URL parsing and changing.")
     (license license:asl2.0)))
 
+(define-public python-canvasapi
+  (package
+    (name "python-canvasapi")
+    (version "2.2.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/ucfopen/canvasapi")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0i13wrq2czcaz3h98pvnsl237104v611y9636jf32b1nn76sbp0p"))))
+    (build-system python-build-system)
+    (propagated-inputs (list python-pytz python-requests))
+    (native-inputs (list python-requests-mock))
+    (home-page "https://github.com/ucfopen/canvasapi")
+    (synopsis "API wrapper for the Canvas LMS")
+    (description
+     "CanvasAPI is a Python library for accessing Instructure’s Canvas LMS API.
+The library enables developers to programmatically manage Canvas courses,
+users, gradebooks, and more.")
+    (license license:expat)))
+
 (define-public python-google
   (package
     (name "python-google")
-- 
2.34.0