diff mbox series

[bug#46651] New package: vmtouch

Message ID Esn-FOxuJF72cASCJyqRijvNL9GJHuJBpUsf4o4gsVjcrCVG6wBpaeSIcRP3ytrQWbTyd-WAiO2_-krFBPMKoi0t90cn6Pegy-dC27hz0WM=@protonmail.com
State Accepted
Headers show
Series [bug#46651] New package: vmtouch | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

qblade Feb. 20, 2021, 1:26 a.m. UTC
Hi everyone, I added a new package.

Comments

Nicolas Goaziou Feb. 21, 2021, 12:45 a.m. UTC | #1
Hello,

qblade via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/admin.scm (vmtouch): New variable.

Applied. Thank you.

I changed the synopsis, using "Portable file system cache diagnostics
and control" instead.

Regards,-- 
Nicolas Goaziou
diff mbox series

Patch

From 7d89493a2151fe59fdeeb46a6911af3ba6ef2fc4 Mon Sep 17 00:00:00 2001
From: qblade <qblade@protonmail.com>
Date: Sat, 20 Feb 2021 01:21:24 +0000
Subject: [PATCH] gnu: add vmtouch.

* gnu/packages/admin.scm (vmtouch): New variable.
---
 gnu/packages/admin.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)

diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index a6cf633baa..161a83c710 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -35,6 +35,7 @@ 
 ;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
 ;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
 ;;; Copyright © 2020 Morgan Smith <Morgan.J.Smith@outlook.com>
+;;; Copyright © 2021 qblade <qblade@protonmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -4383,3 +4384,34 @@  the XMODEM/YMODEM/ZMODEM file transfer protocols.")
 setup, maintenance, supervision, or any long-running processes.")
     (home-page "https://github.com/leahneukirchen/nq")
     (license license:public-domain)))
+
+(define-public vmtouch
+  (package
+    (name "vmtouch")
+    (version "1.3.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/hoytech/vmtouch/")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "08da6apzfkfjwasn4dxrlfxqfx7arl28apdzac5nvm0fhvws0dxk"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("perl" ,perl)))
+    (arguments
+     `(#:tests? #f ; no tests
+       #:make-flags
+       (list
+        (string-append "CC=" ,(cc-for-target))
+        (string-append "PREFIX=" (assoc-ref %outputs "out")))
+       #:phases
+       (modify-phases %standard-phases
+         (delete 'configure))))
+    (home-page "https://github.com/hoytech/vmtouch/")
+    (synopsis "The Virtual Memory Toucher")
+    (description "vmtouch is a tool for learning about and controlling
+the file system cache of unix and unix-like systems.")
+    (license license:bsd-3)))
-- 
2.29.2