[bug#34523] Add tetrinet

Message ID E1hECwe-0005K1-Bj@rmmprod05.runbox
State Accepted
Headers show
Series [bug#34523] Add tetrinet | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

pkill9 April 10, 2019, 1:07 p.m. UTC
I've attached a patch with an updated source url pointing to the git repository which is served via https.

Patch

From 24fb08762c1cb3108495c492ea5f1c7ee855a804 Mon Sep 17 00:00:00 2001
From: Pkill -9 <pkill9@runbox.com>
Date: Wed, 10 Apr 2019 13:49:25 +0100
Subject: [PATCH] gnu: Add tetrinet.

* gnu/packages/games.scm (tetrinet): New variable.
---
 gnu/packages/games.scm | 42 ++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 42 insertions(+)

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index f82af0e8c3..6d5b154927 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -36,6 +36,7 @@ 
 ;;; Copyright © 2018 Madalin Ionel-Patrascu <madalinionel.patrascu@mdc-berlin.de>
 ;;; Copyright © 2018 Benjamin Slade <slade@jnanam.net>
 ;;; Copyright © 2018 Alex Vong <alexvong1995@gmail.com>
+;;; Copyright © 2019 Pkill -9 <pkill9@runbox.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -6102,3 +6103,44 @@  to download and install them in @file{$HOME/.stepmania-X.Y/Songs} directory.")
     (home-page "https://www.stepmania.com")
     (license license:expat)))
 
+(define-public tetrinet
+  (package
+    (name "tetrinet")
+    (version "0.11")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://repo.or.cz/tetrinet.git")
+             (commit "REL_0_11")))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "1zxd78kwc3p4f10r64z9cqjq77shgyinyrigcx1zn0l4d7qsxg6m"))))
+    (build-system gnu-build-system)
+    (inputs
+     `(("ncurses" ,ncurses)))
+    (arguments
+     `(#:tests? #f ; no tests
+       #:make-flags '("CC=gcc")
+       #:phases (modify-phases %standard-phases
+                  (delete 'configure) ; no configure script.
+                  (add-after 'unpack 'fix-install-dir
+                    (lambda* (#:key outputs #:allow-other-keys)
+                      (let ((out (assoc-ref outputs "out")))
+                        (mkdir-p (string-append out "/bin"))
+                        (substitute* "Makefile"
+                          (("/usr/games") (string-append out "/bin"))))))
+                  (add-after 'install 'install-documentation
+                    (lambda* (#:key outputs #:allow-other-keys)
+                      (let* ((out (assoc-ref outputs "out"))
+                             (doc (string-append out "/share/doc/" ,name "-" ,version)))
+                        (for-each (lambda (file)
+                                    (install-file file doc))
+                                  (list "README" "tetrinet.txt"))
+                        #t))))))
+    (home-page "http://tetrinet.or.cz")
+    (synopsis "Multiplayer tetris game")
+    (description "TetriNET is a console multiplayer online Tetris game for
+up to six people.  This package includes the server.")
+    (license license:public-domain)))
-- 
2.21.0