[bug#34523] Add tetrinet

Message ID E1gvcri-0006jX-4B@rmmprod05.runbox
State Accepted
Headers show
Series [bug#34523] Add tetrinet | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

pkill9 Feb. 18, 2019, 6:57 a.m. UTC
Tetrinet is a multiplayer tetris game. There are two versions: a command line implementation and a GTK implementation - this package is the command line implementation. http://tetrinet.or.cz/

The license is written in the README as

```
Distribution/license information
--------------------------------
This program is public domain, and may be modified and distributed without
limitation.
```

So I don't know what license to put it as, so I set it as 'expat'.

Comments

Ricardo Wurmus Feb. 18, 2019, 10:36 a.m. UTC | #1
pkill9@runbox.com writes:

> The license is written in the README as
>
> ```
> Distribution/license information
> --------------------------------
> This program is public domain, and may be modified and distributed without
> limitation.
> ```
>
> So I don't know what license to put it as, so I set it as 'expat'.

“expat” is not correct.  Use “public-domain” instead.

> +       #:phases (modify-phases %standard-phases
> +                  (delete 'configure)
> +                  (add-after 'unpack 'fix-install-dir
> +                    (lambda* (#:key outputs #:allow-other-keys)
> +                      (let ((out (assoc-ref outputs "out")))
> +                        (mkdir-p (string-append out "/bin"))
> +                        (substitute* "Makefile"
> +                          (("/usr/games") (string-append out "/bin")))))))))

Can this patching be avoided by passing a make flag instead?

--
Ricardo
Tobias Geerinckx-Rice Feb. 18, 2019, 2:11 p.m. UTC | #2
pkill -9, Ricardo,

Ricardo Wurmus wrote:
> pkill9@runbox.com writes:
>> +     `(#:tests? #f ; No tests.

Only nitpicks:

+     `(#:tests? #f                      ; no tests

If you're using emacs, running C-M-q on the whole definition will 
automatically indent your code.  There's a way to do the same 
without emacs, but I forget how.

>> +       #:phases (modify-phases %standard-phases
>> +                  (delete 'configure)

+                  (delete 'configure)   ; no configure script

>> +                  (add-after 'unpack 'fix-install-dir
>> +                    (lambda* (#:key outputs 
>> #:allow-other-keys)
>> +                      (let ((out (assoc-ref outputs "out")))
>> +                        (mkdir-p (string-append out "/bin"))
>> +                        (substitute* "Makefile"
>> +                          (("/usr/games") (string-append out 
>> "/bin")))))))))
>
> Can this patching be avoided by passing a make flag instead?

Nope, it's hard-coded in the Makefile target :-(

Considering the lack of a man(ual) page, how about adding 
something like:

  (add-after 'install 'install-documentation
    (lambda* (#:key outputs #:allow-other-keys)
      (let* ((out (assoc-ref outputs "out"))
             (doc (string-append out "/share/doc/"
                                 ,name "-" ,version)))
        (for-each (lambda (file)
                    (install-file file doc))
                  (list "README" "tetrinet.txt"))
        #t))))))

Thanks!

T G-R
Danny Milosavljevic Feb. 18, 2019, 2:41 p.m. UTC | #3
On Mon, 18 Feb 2019 15:11:37 +0100
Tobias Geerinckx-Rice <me@tobias.gr> wrote:

> pkill -9, Ricardo,
> 
> Ricardo Wurmus wrote:
> > pkill9@runbox.com writes:  
> >> +     `(#:tests? #f ; No tests.  
> 
> Only nitpicks:
> 
> +     `(#:tests? #f                      ; no tests
> 
> If you're using emacs, running C-M-q on the whole definition will 
> automatically indent your code.  There's a way to do the same 
> without emacs, but I forget how.

# In guix's git checkout:

guix environment --fallback --ad-hoc emacs emacs-guix -- emacs --script ./etc/indent-code.el "${modulename}" "${packagename}"
swedebugia Feb. 23, 2019, 9:23 a.m. UTC | #4
Danny Milosavljevic <dannym@scratchpost.org> skrev: (18 februari 2019 15:41:33 CET)
>On Mon, 18 Feb 2019 15:11:37 +0100
>Tobias Geerinckx-Rice <me@tobias.gr> wrote:
>
>> pkill -9, Ricardo,
>> 
>> Ricardo Wurmus wrote:
>> > pkill9@runbox.com writes:  
>> >> +     `(#:tests? #f ; No tests.  
>> 
>> Only nitpicks:
>> 
>> +     `(#:tests? #f                      ; no tests
>> 
>> If you're using emacs, running C-M-q on the whole definition will 
>> automatically indent your code.  There's a way to do the same 
>> without emacs, but I forget how.
>
># In guix's git checkout:
>
>guix environment --fallback --ad-hoc emacs emacs-guix -- emacs --script
>./etc/indent-code.el "${modulename}" "${packagename}"

Thanks for the snippet.  I think we should add it to the manual. Thoughts?
pkill9 Feb. 27, 2019, 2:11 p.m. UTC | #5
The Tetrinet maintainer added an SHA1 file: http://tetrinet.or.cz/download/tetrinet-0.11.tar.bz2.sha1

On Wed, 27 Feb 2019 07:10:46 +0000 (GMT), <pkill9@runbox.com> wrote:

> > Given that there is no pgp signed tarball or even a checksum on that page,  have you asked the maintainer about this and verified that you got the code unaltered? 
> 
> Ok I emailed the current maintainer according to that page asking to verify that I got the source code unaltered, and to maybe update the page with that info.
> 
> On Tue, 26 Feb 2019 21:45:23 +0100, swedebugia <swedebugia@riseup.net> wrote:
> 
> > pkill9@runbox.com skrev: (26 februari 2019 16:20:28 CET)
> > >Hi Swedebugia,
> > >
> > >> having looked it up online I prefer the WP synopsis:
> > >> "TetriNET is a console multiplayer online Tetris game for up to six
> > >people."
> > >> 
> > >> There is a gnome version also. We should state clearly that this is a
> > >> console/text-mode client.
> > >
> > >What does 'WP' mean?
> > >
> > >> As an aside I did not find a working server anywhere and the homepage
> > >of
> > >> the project is dead. There is a possibility to host your own server
> > >with
> > >> jetrix though.
> > >
> > >I played Tetrinet with someone over a server, but I can't remember what
> > >the address was.
> > >
> > >You can't access the homepage of the project? I can access
> > >http://tetrinet.or.cz fine. Or do you mean it hasn't been updated in
> > >ages?
> > >
> > >> There could be trademark issues with the name/game also see
> > >> https://en.wikipedia.org/wiki/The_Tetris_Company
> > >
> > >Regarding the potential trademark issues, both FSF-approved distros
> > >Parabola and PureOS have Tetrinet in their repositories[1][2], so I
> > >think it would be acceptable to add it to Guix. And if a copyright
> > >claim is made in the future it can always be removed.
> > >
> > >[1] Tetrinet in Parabola - https://www.parabola.nu/packages/?q=tetrinet
> > >[2] Tetrinet in PureOS -
> > >https://software.pureos.net/search_pkg?term=tetrinet
> > >
> > >Thanks
> > >
> > >On Sat, 23 Feb 2019 07:23:43 +0100, swedebugia <swedebugia@riseup.net>
> > >wrote:
> > >
> > >> On 2019-02-23 10:26, swedebugia wrote:
> > >> > For the sake of making it easy to find when searching synopsies I
> > >> > suggest you add "game" to the end of yours.
> > >> > -- 
> > >> > Sent from my k-9 mail for Android.
> > >> 
> > >> having looked it up online I prefer the WP synopsis:
> > >> "TetriNET is a console multiplayer online Tetris game for up to six
> > >people."
> > >> 
> > >> There is a gnome version also. We should state clearly that this is a
> > >> console/text-mode client.
> > >> 
> > >> As an aside I did not find a working server anywhere and the homepage
> > >of
> > >> the project is dead. There is a possibility to host your own server
> > >with
> > >> jetrix though.
> > >> 
> > >> There could be trademark issues with the name/game also see
> > >> https://en.wikipedia.org/wiki/The_Tetris_Company
> > >> 
> > >> -- 
> > >> Cheers Swedebugia
> > 
> > Hi 
> > I agree with your remarks
> > WP = wikipedia 
> > 
> > Given that there is no pgp signed tarball or even a checksum on that page,  have you asked the maintainer about this and verified that you got the code unaltered? 
> > -- 
> > Sent from my k-9 mail for Android.
swedebugia Feb. 28, 2019, 4:03 a.m. UTC | #6
pkill9@runbox.com skrev: (27 februari 2019 15:11:20 CET)
>The Tetrinet maintainer added an SHA1 file:
>http://tetrinet.or.cz/download/tetrinet-0.11.tar.bz2.sha1
>
>On Wed, 27 Feb 2019 07:10:46 +0000 (GMT), <pkill9@runbox.com> wrote:
>
>> > Given that there is no pgp signed tarball or even a checksum on
>that page,  have you asked the maintainer about this and verified that
>you got the code unaltered? 
>> 
>> Ok I emailed the current maintainer according to that page asking to
>verify that I got the source code unaltered, and to maybe update the
>page with that info.
>> 
>> On Tue, 26 Feb 2019 21:45:23 +0100, swedebugia
><swedebugia@riseup.net> wrote:
>> 
>> > pkill9@runbox.com skrev: (26 februari 2019 16:20:28 CET)
>> > >Hi Swedebugia,
>> > >
>> > >> having looked it up online I prefer the WP synopsis:
>> > >> "TetriNET is a console multiplayer online Tetris game for up to
>six
>> > >people."
>> > >> 
>> > >> There is a gnome version also. We should state clearly that this
>is a
>> > >> console/text-mode client.
>> > >
>> > >What does 'WP' mean?
>> > >
>> > >> As an aside I did not find a working server anywhere and the
>homepage
>> > >of
>> > >> the project is dead. There is a possibility to host your own
>server
>> > >with
>> > >> jetrix though.
>> > >
>> > >I played Tetrinet with someone over a server, but I can't remember
>what
>> > >the address was.
>> > >
>> > >You can't access the homepage of the project? I can access
>> > >http://tetrinet.or.cz fine. Or do you mean it hasn't been updated
>in
>> > >ages?
>> > >
>> > >> There could be trademark issues with the name/game also see
>> > >> https://en.wikipedia.org/wiki/The_Tetris_Company
>> > >
>> > >Regarding the potential trademark issues, both FSF-approved
>distros
>> > >Parabola and PureOS have Tetrinet in their repositories[1][2], so
>I
>> > >think it would be acceptable to add it to Guix. And if a copyright
>> > >claim is made in the future it can always be removed.
>> > >
>> > >[1] Tetrinet in Parabola -
>https://www.parabola.nu/packages/?q=tetrinet
>> > >[2] Tetrinet in PureOS -
>> > >https://software.pureos.net/search_pkg?term=tetrinet
>> > >
>> > >Thanks
>> > >
>> > >On Sat, 23 Feb 2019 07:23:43 +0100, swedebugia
><swedebugia@riseup.net>
>> > >wrote:
>> > >
>> > >> On 2019-02-23 10:26, swedebugia wrote:
>> > >> > For the sake of making it easy to find when searching
>synopsies I
>> > >> > suggest you add "game" to the end of yours.
>> > >> > -- 
>> > >> > Sent from my k-9 mail for Android.
>> > >> 
>> > >> having looked it up online I prefer the WP synopsis:
>> > >> "TetriNET is a console multiplayer online Tetris game for up to
>six
>> > >people."
>> > >> 
>> > >> There is a gnome version also. We should state clearly that this
>is a
>> > >> console/text-mode client.
>> > >> 
>> > >> As an aside I did not find a working server anywhere and the
>homepage
>> > >of
>> > >> the project is dead. There is a possibility to host your own
>server
>> > >with
>> > >> jetrix though.
>> > >> 
>> > >> There could be trademark issues with the name/game also see
>> > >> https://en.wikipedia.org/wiki/The_Tetris_Company
>> > >> 
>> > >> -- 
>> > >> Cheers Swedebugia
>> > 
>> > Hi 
>> > I agree with your remarks
>> > WP = wikipedia 
>> > 
>> > Given that there is no pgp signed tarball or even a checksum on
>that page,  have you asked the maintainer about this and verified that
>you got the code unaltered? 
>> > -- 
>> > Sent from my k-9 mail for Android.

Good, did you point out that http is easy to spoof?

If they are serious about application and distribution security they really should enable https.

I had the same issue with another maintainer serving a hash over http. I asked him over email if my hash was correct. This is not perfect out of band but given most email providers post snowden now use starttls and enforce https it is better than nothing.

Assuming it is tainted is my default stance with http. I would rather not use it at all and would like a browser that drops it or issue a dire warning when encountered.
pkill9 March 2, 2019, 8:10 p.m. UTC | #7
This was their reply:

```
Hi,

I'm not sure how it confirms its validity further :), but it's:
2fb2bfcfe1fc2af82b01b66e2b28a77ad1262c17

The last release of tetrinet was about 15 years ago, this is a purely
legacy archive - I haven't considered adding an https certificate, sorry.
```

On Thu, 28 Feb 2019 05:03:50 +0100, swedebugia <swedebugia@riseup.net> wrote:

> pkill9@runbox.com skrev: (27 februari 2019 15:11:20 CET)
> >The Tetrinet maintainer added an SHA1 file:
> >http://tetrinet.or.cz/download/tetrinet-0.11.tar.bz2.sha1
> >
> >On Wed, 27 Feb 2019 07:10:46 +0000 (GMT), <pkill9@runbox.com> wrote:
> >
> >> > Given that there is no pgp signed tarball or even a checksum on
> >that page,  have you asked the maintainer about this and verified that
> >you got the code unaltered? 
> >> 
> >> Ok I emailed the current maintainer according to that page asking to
> >verify that I got the source code unaltered, and to maybe update the
> >page with that info.
> >> 
> >> On Tue, 26 Feb 2019 21:45:23 +0100, swedebugia
> ><swedebugia@riseup.net> wrote:
> >> 
> >> > pkill9@runbox.com skrev: (26 februari 2019 16:20:28 CET)
> >> > >Hi Swedebugia,
> >> > >
> >> > >> having looked it up online I prefer the WP synopsis:
> >> > >> "TetriNET is a console multiplayer online Tetris game for up to
> >six
> >> > >people."
> >> > >> 
> >> > >> There is a gnome version also. We should state clearly that this
> >is a
> >> > >> console/text-mode client.
> >> > >
> >> > >What does 'WP' mean?
> >> > >
> >> > >> As an aside I did not find a working server anywhere and the
> >homepage
> >> > >of
> >> > >> the project is dead. There is a possibility to host your own
> >server
> >> > >with
> >> > >> jetrix though.
> >> > >
> >> > >I played Tetrinet with someone over a server, but I can't remember
> >what
> >> > >the address was.
> >> > >
> >> > >You can't access the homepage of the project? I can access
> >> > >http://tetrinet.or.cz fine. Or do you mean it hasn't been updated
> >in
> >> > >ages?
> >> > >
> >> > >> There could be trademark issues with the name/game also see
> >> > >> https://en.wikipedia.org/wiki/The_Tetris_Company
> >> > >
> >> > >Regarding the potential trademark issues, both FSF-approved
> >distros
> >> > >Parabola and PureOS have Tetrinet in their repositories[1][2], so
> >I
> >> > >think it would be acceptable to add it to Guix. And if a copyright
> >> > >claim is made in the future it can always be removed.
> >> > >
> >> > >[1] Tetrinet in Parabola -
> >https://www.parabola.nu/packages/?q=tetrinet
> >> > >[2] Tetrinet in PureOS -
> >> > >https://software.pureos.net/search_pkg?term=tetrinet
> >> > >
> >> > >Thanks
> >> > >
> >> > >On Sat, 23 Feb 2019 07:23:43 +0100, swedebugia
> ><swedebugia@riseup.net>
> >> > >wrote:
> >> > >
> >> > >> On 2019-02-23 10:26, swedebugia wrote:
> >> > >> > For the sake of making it easy to find when searching
> >synopsies I
> >> > >> > suggest you add "game" to the end of yours.
> >> > >> > -- 
> >> > >> > Sent from my k-9 mail for Android.
> >> > >> 
> >> > >> having looked it up online I prefer the WP synopsis:
> >> > >> "TetriNET is a console multiplayer online Tetris game for up to
> >six
> >> > >people."
> >> > >> 
> >> > >> There is a gnome version also. We should state clearly that this
> >is a
> >> > >> console/text-mode client.
> >> > >> 
> >> > >> As an aside I did not find a working server anywhere and the
> >homepage
> >> > >of
> >> > >> the project is dead. There is a possibility to host your own
> >server
> >> > >with
> >> > >> jetrix though.
> >> > >> 
> >> > >> There could be trademark issues with the name/game also see
> >> > >> https://en.wikipedia.org/wiki/The_Tetris_Company
> >> > >> 
> >> > >> -- 
> >> > >> Cheers Swedebugia
> >> > 
> >> > Hi 
> >> > I agree with your remarks
> >> > WP = wikipedia 
> >> > 
> >> > Given that there is no pgp signed tarball or even a checksum on
> >that page,  have you asked the maintainer about this and verified that
> >you got the code unaltered? 
> >> > -- 
> >> > Sent from my k-9 mail for Android.
> 
> Good, did you point out that http is easy to spoof?
> 
> If they are serious about application and distribution security they really should enable https.
> 
> I had the same issue with another maintainer serving a hash over http. I asked him over email if my hash was correct. This is not perfect out of band but given most email providers post snowden now use starttls and enforce https it is better than nothing.
> 
> Assuming it is tainted is my default stance with http. I would rather not use it at all and would like a browser that drops it or issue a dire warning when encountered. 
> -- 
> Sent from my k-9 mail for Android.
pkill9 March 31, 2019, 11:44 a.m. UTC | #8
So I looked at the PureOS page for Tetrinet (https://software.pureos.net/package/source/landing/tetrinet) and the "VCS browser" links to a git repository for Tetrinet which is served via https: https://repo.or.cz/tetrinet.git, this is linked to on the frontpage of http://tetrinet.or.cz (a link to the README) file, so I'll change the source to use this instead.

On Thu, 28 Feb 2019 05:03:50 +0100, swedebugia <swedebugia@riseup.net> wrote:

> pkill9@runbox.com skrev: (27 februari 2019 15:11:20 CET)
> >The Tetrinet maintainer added an SHA1 file:
> >http://tetrinet.or.cz/download/tetrinet-0.11.tar.bz2.sha1
> >
> >On Wed, 27 Feb 2019 07:10:46 +0000 (GMT), <pkill9@runbox.com> wrote:
> >
> >> > Given that there is no pgp signed tarball or even a checksum on
> >that page,  have you asked the maintainer about this and verified that
> >you got the code unaltered? 
> >> 
> >> Ok I emailed the current maintainer according to that page asking to
> >verify that I got the source code unaltered, and to maybe update the
> >page with that info.
> >> 
> >> On Tue, 26 Feb 2019 21:45:23 +0100, swedebugia
> ><swedebugia@riseup.net> wrote:
> >> 
> >> > pkill9@runbox.com skrev: (26 februari 2019 16:20:28 CET)
> >> > >Hi Swedebugia,
> >> > >
> >> > >> having looked it up online I prefer the WP synopsis:
> >> > >> "TetriNET is a console multiplayer online Tetris game for up to
> >six
> >> > >people."
> >> > >> 
> >> > >> There is a gnome version also. We should state clearly that this
> >is a
> >> > >> console/text-mode client.
> >> > >
> >> > >What does 'WP' mean?
> >> > >
> >> > >> As an aside I did not find a working server anywhere and the
> >homepage
> >> > >of
> >> > >> the project is dead. There is a possibility to host your own
> >server
> >> > >with
> >> > >> jetrix though.
> >> > >
> >> > >I played Tetrinet with someone over a server, but I can't remember
> >what
> >> > >the address was.
> >> > >
> >> > >You can't access the homepage of the project? I can access
> >> > >http://tetrinet.or.cz fine. Or do you mean it hasn't been updated
> >in
> >> > >ages?
> >> > >
> >> > >> There could be trademark issues with the name/game also see
> >> > >> https://en.wikipedia.org/wiki/The_Tetris_Company
> >> > >
> >> > >Regarding the potential trademark issues, both FSF-approved
> >distros
> >> > >Parabola and PureOS have Tetrinet in their repositories[1][2], so
> >I
> >> > >think it would be acceptable to add it to Guix. And if a copyright
> >> > >claim is made in the future it can always be removed.
> >> > >
> >> > >[1] Tetrinet in Parabola -
> >https://www.parabola.nu/packages/?q=tetrinet
> >> > >[2] Tetrinet in PureOS -
> >> > >https://software.pureos.net/search_pkg?term=tetrinet
> >> > >
> >> > >Thanks
> >> > >
> >> > >On Sat, 23 Feb 2019 07:23:43 +0100, swedebugia
> ><swedebugia@riseup.net>
> >> > >wrote:
> >> > >
> >> > >> On 2019-02-23 10:26, swedebugia wrote:
> >> > >> > For the sake of making it easy to find when searching
> >synopsies I
> >> > >> > suggest you add "game" to the end of yours.
> >> > >> > -- 
> >> > >> > Sent from my k-9 mail for Android.
> >> > >> 
> >> > >> having looked it up online I prefer the WP synopsis:
> >> > >> "TetriNET is a console multiplayer online Tetris game for up to
> >six
> >> > >people."
> >> > >> 
> >> > >> There is a gnome version also. We should state clearly that this
> >is a
> >> > >> console/text-mode client.
> >> > >> 
> >> > >> As an aside I did not find a working server anywhere and the
> >homepage
> >> > >of
> >> > >> the project is dead. There is a possibility to host your own
> >server
> >> > >with
> >> > >> jetrix though.
> >> > >> 
> >> > >> There could be trademark issues with the name/game also see
> >> > >> https://en.wikipedia.org/wiki/The_Tetris_Company
> >> > >> 
> >> > >> -- 
> >> > >> Cheers Swedebugia
> >> > 
> >> > Hi 
> >> > I agree with your remarks
> >> > WP = wikipedia 
> >> > 
> >> > Given that there is no pgp signed tarball or even a checksum on
> >that page,  have you asked the maintainer about this and verified that
> >you got the code unaltered? 
> >> > -- 
> >> > Sent from my k-9 mail for Android.
> 
> Good, did you point out that http is easy to spoof?
> 
> If they are serious about application and distribution security they really should enable https.
> 
> I had the same issue with another maintainer serving a hash over http. I asked him over email if my hash was correct. This is not perfect out of band but given most email providers post snowden now use starttls and enforce https it is better than nothing.
> 
> Assuming it is tainted is my default stance with http. I would rather not use it at all and would like a browser that drops it or issue a dire warning when encountered. 
> -- 
> Sent from my k-9 mail for Android.

Patch

From 1e36c7b0cafac68dcac43bfe301ae979ced67800 Mon Sep 17 00:00:00 2001
From: Pkill -9 <pkill9@runbox.com>
Date: Mon, 18 Feb 2019 06:52:14 +0000
Subject: [PATCH] gnu: Add tetrinet.

* gnu/packages/games.scm (tetrinet): New variable.
---
 gnu/packages/games.scm | 34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index f82af0e8c..5a83efcc2 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -36,6 +36,7 @@ 
 ;;; Copyright © 2018 Madalin Ionel-Patrascu <madalinionel.patrascu@mdc-berlin.de>
 ;;; Copyright © 2018 Benjamin Slade <slade@jnanam.net>
 ;;; Copyright © 2018 Alex Vong <alexvong1995@gmail.com>
+;;; Copyright © 2019 Pkill -9 <pkill9@runbox.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -6102,3 +6103,36 @@  to download and install them in @file{$HOME/.stepmania-X.Y/Songs} directory.")
     (home-page "https://www.stepmania.com")
     (license license:expat)))
 
+(define-public tetrinet
+  (package
+    (name "tetrinet")
+    (version "0.11")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "http://tetrinet.or.cz/download/tetrinet-"
+             version
+             ".tar.bz2"))
+       (sha256
+        (base32
+         "0b4pddqz6is1771qmvcj8qqlr4in2djdbkk13agvp9yhfah2v8x7"))))
+    (build-system gnu-build-system)
+    (inputs
+     `(("ncurses" ,ncurses)))
+    (arguments
+     `(#:tests? #f ; No tests.
+       #:make-flags '("CC=gcc")
+       #:phases (modify-phases %standard-phases
+                  (delete 'configure)
+                  (add-after 'unpack 'fix-install-dir
+                    (lambda* (#:key outputs #:allow-other-keys)
+                      (let ((out (assoc-ref outputs "out")))
+                        (mkdir-p (string-append out "/bin"))
+                        (substitute* "Makefile"
+                          (("/usr/games") (string-append out "/bin")))))))))
+    (home-page "http://tetrinet.or.cz")
+    (synopsis "Multiplayer tetris")
+    (description "Tetrinet is a multiplayer tetris game with powerups and
+attacks you can use on opponents.")
+    (license license:expat)))
-- 
2.20.1