diff mbox series

[bug#57999] gnu: Add textpieces

Message ID Ds6JEIbIgEzjlRgFHWZTxJkyaagPp77dVdIw2Uj7-5tYEV2vqpRXede0zQnSN_Xlw0rPYEkMTgcRjymRyirozlH4cR-WmPawoSxIisGViT8=@proton.me
State Accepted
Headers show
Series [bug#57999] gnu: Add textpieces | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Sughosha Oct. 17, 2022, 5:19 a.m. UTC
From c5737d59c0854162dfed9f580ca30b2c4a5fdfad Mon Sep 17 00:00:00 2001
From: Sughosha <sughosha@proton.me>
Date: Mon, 17 Oct 2022 07:09:40 +0200
Subject: [PATCH] gnu: textpieces: Reorder dependencies and fix description

* gnu/packages/textpieces.scm (textpieces)[description]: Fix description.
[inputs]: Reorder dependencies.
[native-inputs]: Reorder dependencies.
---
 gnu/packages/text-editors.scm | 22 +++++++++++-----------
 1 file changed, 11 insertions(+), 11 deletions(-)

Comments

Christopher Baines Oct. 18, 2022, 10:15 a.m. UTC | #1
Sughosha <Sughosha@proton.me> writes:

> From c5737d59c0854162dfed9f580ca30b2c4a5fdfad Mon Sep 17 00:00:00 2001
> From: Sughosha <sughosha@proton.me>
> Date: Mon, 17 Oct 2022 07:09:40 +0200
> Subject: [PATCH] gnu: textpieces: Reorder dependencies and fix description
>
> * gnu/packages/textpieces.scm (textpieces)[description]: Fix description.
> [inputs]: Reorder dependencies.
> [native-inputs]: Reorder dependencies.
> ---
>  gnu/packages/text-editors.scm | 22 +++++++++++-----------
>  1 file changed, 11 insertions(+), 11 deletions(-)

Thanks, I've pushed this to master as
3c7d4fdc30530f35005d2555a50bbe9fa4b12da7.

Chris
diff mbox series

Patch

diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index dacd2ef80d..f278b0902c 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -920,28 +920,28 @@  (define-public textpieces
        #:glib-or-gtk? #t))
     (build-system meson-build-system)
     (native-inputs
-     (list pkg-config
-           vala
+     (list appstream-glib
+           blueprint-compiler
            desktop-file-utils
-           appstream-glib
            gettext-minimal
-           blueprint-compiler
            `(,glib "bin")
-           `(,gtk "bin")))
+           `(,gtk "bin")
+           pkg-config
+           vala))
     (inputs
-     (list json-glib
+     (list gtk
+           gtksourceview
+           json-glib
            libadwaita
            libgee
            python
            python-pygobject
-           python-pyyaml
-           gtk
-           gtksourceview))
+           python-pyyaml))
     (home-page "https://github.com/liferooter/textpieces")
     (synopsis "Quick text processor")
     (description
-     "Text Pieces tool for quick text transformations such as checksums,
-encoding, decoding and so on.
+     "Text Pieces is a tool for quick text transformations such as checksums,
+encoding, decoding, etc.
 
 The basic features of Text Pieces are:
 @itemize