From 65af6af99389899c53ea57d5d15548b7a2bf3014 Mon Sep 17 00:00:00 2001
From: Petr Hodina <phodina@protonmail.com>
Date: Tue, 7 Jun 2022 08:11:33 +0200
Subject: [PATCH] gnu: Add kismet.
* gnu/packages/networking.scm (kismet): New variable.
@@ -49,6 +49,7 @@
;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
;;; Copyright © 2022 Simon South <simon@simonsouth.net>
;;; Copyright © 2022 Pierre Langlois <pierre.langlois@gmx.com>
+;;; Copyright © 2022 Petr Hodina <phodina@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -114,6 +115,7 @@ (define-module (gnu packages networking)
#:use-module (gnu packages image)
#:use-module (gnu packages libevent)
#:use-module (gnu packages libidn)
+ #:use-module (gnu packages libusb)
#:use-module (gnu packages linux)
#:use-module (gnu packages lua)
#:use-module (gnu packages kerberos)
@@ -129,6 +131,7 @@ (define-module (gnu packages networking)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages polkit)
#:use-module (gnu packages pretty-print)
+ #:use-module (gnu packages protobuf)
#:use-module (gnu packages pulseaudio)
#:use-module (gnu packages python)
#:use-module (gnu packages python-crypto)
@@ -547,6 +550,42 @@ (define-public python-pysctp
SCTP-aware kernel (most are).")
(license license:lgpl2.1+)))
+(define-public kismet
+ (package
+ (name "kismet")
+ (version "2022-02")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/kismetwireless/kismet")
+ (commit (string-append "kismet-" version "-R1"))))
+ (sha256
+ (base32
+ "01q86hrgpai433sc65dlnqy91qd26w5dwyp37adszqxfb6d2an1r"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:tests? #f ; no test suite
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-install
+ (lambda* _
+ (substitute* "Makefile.in"
+ (("-o \\$\\(INSTUSR\\) -g \\$\\(SUIDGROUP\\)") "")
+ (("-o \\$\\(INSTUSR\\) -g \\$\\(INSTGRP\\)") "")))))))
+ (home-page "https://www.kismetwireless.net/")
+ (native-inputs (list pkg-config python python-2 perl))
+ (inputs (list openssl libpcap libusb protobuf protobuf-c libwebsockets sqlite zlib))
+ (synopsis "Wireless network and device detector")
+ (description
+ "This package provides a wireless network and device detector, sniffer,
+wardriving tool, and WIDS (wireless intrusion detection) framework. Kismet
+works with Wi-Fi interfaces, Bluetooth interfaces, some SDR
+(software defined radio) hardware like the RTLSDR, and other specialized
+capture hardware")
+ (license license:gpl2+)))
+
(define-public knockd
(package
(name "knockd")
--
2.35.1