diff mbox series

[bug#64957,vREVISION] gnu: Add python-fontmake.

Message ID DU2P193MB2132F9200C4E07100F136590F304A@DU2P193MB2132.EURP193.PROD.OUTLOOK.COM
State New
Headers show
Series [bug#64957,vREVISION] gnu: Add python-fontmake. | expand

Commit Message

Sergio Pastor Pérez July 30, 2023, 3:45 p.m. UTC
* gnu/packages/fontutils.scm (python-fontmake): New variable.
---
Drop `python-` prefix since fontmake is not being used as a python library rather as a stand-alone application.

 gnu/packages/fontutils.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)


base-commit: c173819c8e5235ce02d60b79bd88b10023a7c614
prerequisite-patch-id: c56db9fa7fc4e07452dea53f2d450bd83abbbc1a
prerequisite-patch-id: 3e6318d61f2efa01f4435152f2139eef8f72572c
prerequisite-patch-id: 1b23c59bab92820a1e102137909922f4d71ed8f9
prerequisite-patch-id: 78a291411f8d86beabbf6d49df0cc78702ad4e65
prerequisite-patch-id: 579224b39cae7869ce11e2e8dba046b5eef606c7
prerequisite-patch-id: f1f62fd5d83d603ca35c17071e615352e90753e3
prerequisite-patch-id: 1843bca37f83e494be67c24e975727fb1fe1248c
prerequisite-patch-id: 5cc0d6cd16ae2ab21c444ed9cabfeea5615e8cda
prerequisite-patch-id: 92a3fab6e4174a4d4877fc5b426752df81e4df39
prerequisite-patch-id: ebf3fd3a8bb02f7dc5cdf504f63d5028b29fe69e

Comments

Hilton Chain July 30, 2023, 6:06 p.m. UTC | #1
Hi Sergio,

On Sun, 30 Jul 2023 23:45:20 +0800,
Sergio Pastor Pérez wrote:
>
> * gnu/packages/fontutils.scm (python-fontmake): New variable.
> ---

Please adjust the commit message as well.

> +    (version "3.4.0")

The latest version is 3.6.1, can you update the definition for it?

> +    (build-system python-build-system)
> +    (propagated-inputs (list python-attrs

Please change the `propagated-inputs' field into `inputs'.

It's not necessary to propagate those inputs, as python-build-system
already wraps the final fontmake program to find them.

> +    (synopsis
> +     "Compile fonts from sources (UFO, Glyphs) to binary (OpenType, TrueType)")
> +    (description
> +     "Fontmake compiles fonts from various sources (.glyphs, .ufo, designspace) into binaries (.otf, .ttf). You can use it to create static instances and variable fonts.")

There are some format issues, which could also be found by running
`./pre-inst-env guix lint fontmake' in your Guix checkout, I have
attatched the output below.

--8<---------------cut here---------------start------------->8---
gnu/packages/fontutils.scm:535:5: fontmake@3.4.0: sentences in description should be followed by two spaces; possible infraction at 100
gnu/packages/fontutils.scm:535:0: fontmake@3.4.0: line 535 is way too long (171 characters)
gnu/packages/fontutils.scm:531:15: fontmake@3.4.0: permanent redirect from https://github.com/googlei18n/fontmake to https://github.com/googlefonts/fontmake
--8<---------------cut here---------------end--------------->8---

And... The REVISION in the `git send-email' part of the manual should
be replaced with a number, for example:

--8<---------------cut here---------------start------------->8---
$ git send-email --annotate -v2 \
      --to=ISSUE_NUMBER@debbugs.gnu.org -1
--8<---------------cut here---------------end--------------->8---

It's used in the [PATCH v...] part of the title.

Thanks
diff mbox series

Patch

diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index 153602b4b4..98cf573d1e 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -776,6 +776,31 @@  (define-public psautohint-font-data
        ;; Code Pro, Source Serif Pro, all available under the same license.
        (license license:silofl1.1)))))
 
+(define-public fontmake
+  (package
+    (name "fontmake")
+    (version "3.4.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "fontmake" version ".zip"))
+              (sha256
+               (base32
+                "0fc5c9csjpy1aa4c03p7nvjgls5wjplhmmf42n0cmvrlh6cm7wl3"))))
+    (build-system python-build-system)
+    (propagated-inputs (list python-attrs
+                             python-fontmath
+                             python-fonttools-minimal
+                             python-glyphslib
+                             python-ufo2ft
+                             python-ufolib2))
+    (native-inputs (list unzip python-setuptools-scm))
+    (home-page "https://github.com/googlei18n/fontmake")
+    (synopsis
+     "Compile fonts from sources (UFO, Glyphs) to binary (OpenType, TrueType)")
+    (description
+     "Fontmake compiles fonts from various sources (.glyphs, .ufo, designspace) into binaries (.otf, .ttf). You can use it to create static instances and variable fonts.")
+    (license license:asl2.0)))
+
 (define-public psautohint
   (package
     (name "psautohint")