diff mbox series

[bug#65012,v2,1/2] gnu: Add mini.

Message ID DU2P193MB2132CB79EDEB821C8C1C583FF3F3A@DU2P193MB2132.EURP193.PROD.OUTLOOK.COM
State New
Headers show
Series [bug#65012,v2,1/2] gnu: Add mini. | expand

Commit Message

Sergio Pastor PĂ©rez Sept. 10, 2023, 3:42 p.m. UTC
* gnu/packages/image.scm (mini): New variable.
---
This patch bundles the mINI header library. This library includes a series of
tests which have g++, linux-header, and a few other dependencies that get
satisfied with `gcc-toolchain'. For an unknown reason adding the module `gnu
packages commencement` breaks Guile. This patches have been tested under
`GUIX_PACKAGE_PATH` successfully. Also, adding this package definition under a
module which already includes the commencement module does not present the
issue.

For this reason I submit this 2 patches as a proposal. Any further info
regarding the issue described would be appreciated.

 gnu/packages/image.scm | 34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 3336e38852..f84af81384 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -68,6 +68,7 @@  (define-module (gnu packages image)
   #:use-module (gnu packages cpp)
   #:use-module (gnu packages curl)
   #:use-module (gnu packages compression)
+  #:use-module (gnu packages commencement)
   #:use-module (gnu packages documentation)
   #:use-module (gnu packages fontutils)
   #:use-module (gnu packages freedesktop)
@@ -1914,6 +1915,39 @@  (define-public niftilib
     (home-page "https://niftilib.sourceforge.net")
     (license license:public-domain)))
 
+(define-public mini
+  (package
+    (name "mini")
+    (version "0.9.14")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/pulzed/mINI")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "01wn7h9rjz9h6cr11dd62jsb3315d1h6c33pdmwi2l7d8a4n3h8d"))))
+    (build-system copy-build-system)
+    (arguments
+     (list #:install-plan ''(("src/mini/ini.h" "include/mini/ini.h"))
+           #:phases #~(modify-phases %standard-phases
+                        (add-before 'install 'check
+                          (lambda _
+                            (with-directory-excursion "tests"
+                              (for-each (lambda (test)
+                                          (let ((test-name (basename test
+                                                                     ".cpp")))
+                                            (invoke "./build.sh" test-name)
+                                            (invoke "./run.sh" test-name)))
+                                        (find-files "." ".cpp"))))))))
+    (native-inputs (list gcc-toolchain))
+    (home-page "https://github.com/pulzed/mINI")
+    (synopsis "INI file reader and writer header library")
+    (description
+     "This is a tiny, header only C++ library for manipulating INI files.")
+    (license license:expat)))
+
 (define-public gpick
   (package
     (name "gpick")