diff mbox series

[bug#64952] gnu: Add font-pragmasevka.

Message ID DU2P193MB2132BF09C67098D3DC86FC81F304A@DU2P193MB2132.EURP193.PROD.OUTLOOK.COM
State New
Headers show
Series [bug#64952] gnu: Add font-pragmasevka. | expand

Commit Message

Sergio Pastor PĂ©rez July 30, 2023, 11:14 a.m. UTC
* gnu/packages/fonts.scm (font-pragmasevka): New variable.
---
 gnu/packages/fonts.scm | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)


base-commit: c173819c8e5235ce02d60b79bd88b10023a7c614
prerequisite-patch-id: c56db9fa7fc4e07452dea53f2d450bd83abbbc1a
prerequisite-patch-id: 3e6318d61f2efa01f4435152f2139eef8f72572c
prerequisite-patch-id: 1b23c59bab92820a1e102137909922f4d71ed8f9
prerequisite-patch-id: 78a291411f8d86beabbf6d49df0cc78702ad4e65
prerequisite-patch-id: 579224b39cae7869ce11e2e8dba046b5eef606c7
prerequisite-patch-id: f1f62fd5d83d603ca35c17071e615352e90753e3
prerequisite-patch-id: 1843bca37f83e494be67c24e975727fb1fe1248c
diff mbox series

Patch

diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 9786231805..d5fed4911f 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -3418,3 +3418,22 @@  (define-public font-stix-two
     (description
      "The mission of the Scientific and Technical Information Exchange (STIX) font creation project is the preparation of a comprehensive set of fonts that serve the scientific and engineering community in the process from manuscript creation through final publication, both in electronic and print formats.")
     (license license:silofl1.1)))
+
+(define-public font-pragmasevka
+  (package
+    (name "font-pragmasevka")
+    (version "1.6.4")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://github.com/shytikov/pragmasevka/releases/download/v"
+                    version "/Pragmasevka_NF.zip"))
+              (file-name (string-append name version ".zip"))
+              (sha256
+               (base32
+                "099kn1qjjm54izzimc6gzxcffji1nighsdh0zb16gb35qnciyp7d"))))
+    (build-system font-build-system)
+    (home-page "https://github.com/shytikov/pragmasevka.git")
+    (synopsis "Iosevka font variant that mimics PragmataPro")
+    (description "Pragmata Pro doppelgänger made of Iosevka SS08.")
+    (license license:silofl1.1)))