diff mbox series

[bug#66367] gnu: Add gnome-shell-extension-night-theme-switcher.

Message ID DU2P193MB2132BDF67AB99C438380EDA9F3CAA@DU2P193MB2132.EURP193.PROD.OUTLOOK.COM
State New
Headers show
Series [bug#66367] gnu: Add gnome-shell-extension-night-theme-switcher. | expand

Commit Message

Sergio Pastor Pérez Oct. 5, 2023, 9:50 p.m. UTC
* gnu/packages/gnome-xyz.scm (gnome-shell-extension-night-theme-switcher): New variable.
---
Hi.

I'm submitting this patch specifically targeting version 65. Although there are
newer versions of this shell extension, this is the last tagged commit which
supports our version of GNOME, 42.4.

Have a good night,
Sergio.

 gnu/packages/gnome-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)


base-commit: 5694352c05ed4fdb57a9843d8f023ca3d85992c3
prerequisite-patch-id: ea4ff419275abda9520795ef6cdbb563b8874aa4
prerequisite-patch-id: ceafc36e576e35d1b61df4a576688576408b8395
prerequisite-patch-id: a8e9072010c9429a0fb3862268eeede5fde027ff
prerequisite-patch-id: 579224b39cae7869ce11e2e8dba046b5eef606c7
prerequisite-patch-id: 6016c4c37bd61a419885a3a9d3faaf7b08446c1c
prerequisite-patch-id: 1843bca37f83e494be67c24e975727fb1fe1248c
prerequisite-patch-id: 5cc0d6cd16ae2ab21c444ed9cabfeea5615e8cda
prerequisite-patch-id: 92a3fab6e4174a4d4877fc5b426752df81e4df39
prerequisite-patch-id: ebf3fd3a8bb02f7dc5cdf504f63d5028b29fe69e
prerequisite-patch-id: 863acbffb59c3b17fb4ea7e11710cbd793c0778d
prerequisite-patch-id: b9dfcca92d3854e80451750e74cc395244f28da2

Comments

Maxim Cournoyer Oct. 6, 2023, 1:13 p.m. UTC | #1
Hi,

Sergio Pastor Pérez <sergio.pastorperez@outlook.es> writes:

> * gnu/packages/gnome-xyz.scm (gnome-shell-extension-night-theme-switcher): New variable.
> ---
> Hi.
>
> I'm submitting this patch specifically targeting version 65. Although there are
> newer versions of this shell extension, this is the last tagged commit which
> supports our version of GNOME, 42.4.
>
> Have a good night,
> Sergio.
>
>  gnu/packages/gnome-xyz.scm | 24 ++++++++++++++++++++++++
>  1 file changed, 24 insertions(+)
>
> diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
> index 8b5dc3030e..651c958f83 100644
> --- a/gnu/packages/gnome-xyz.scm
> +++ b/gnu/packages/gnome-xyz.scm
> @@ -1050,6 +1050,30 @@ (define-public gnome-shell-extension-paperwm
>  notebooks and tiling window managers.")
>      (license license:gpl3)))
>  
> +(define-public gnome-shell-extension-night-theme-switcher
> +  (package
> +    (name "gnome-shell-extension-night-theme-switcher")
> +    (version "65")
> +    (source
> +     (origin
> +       (method git-fetch)
> +       (uri (git-reference
> +             (url
> +              "https://gitlab.com/rmnvgr/nightthemeswitcher-gnome-shell-extension")
> +             (commit version)))
> +       (sha256
> +        (base32 "0qhi2g2lh6m8vhrmmfi60977f0i4k9x1zj68lrvpzzlqndz8cgh9"))
> +       (file-name (git-file-name name version))))
> +    (build-system meson-build-system)
> +    (native-inputs (list pkg-config
> +                         (list glib "bin")))

nitpick: when there are less than 5 inputs, it's fine to list them on a
single line.

> +    (synopsis "Automatic theme switcher for GNOME Shell")
> +    (description
> +     "Automatically toggle your GNOME desktops color scheme between light and
> +dark, switch backgrounds and run custom commands at sunset and sunrise.")
> +    (home-page "https://nightthemeswitcher.romainvigier.fr")
> +    (license license:gpl2+)))

Thanks.  There seems to be some binary code in the middle of the
description.  Could you check?
diff mbox series

Patch

diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 8b5dc3030e..651c958f83 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -1050,6 +1050,30 @@  (define-public gnome-shell-extension-paperwm
 notebooks and tiling window managers.")
     (license license:gpl3)))
 
+(define-public gnome-shell-extension-night-theme-switcher
+  (package
+    (name "gnome-shell-extension-night-theme-switcher")
+    (version "65")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url
+              "https://gitlab.com/rmnvgr/nightthemeswitcher-gnome-shell-extension")
+             (commit version)))
+       (sha256
+        (base32 "0qhi2g2lh6m8vhrmmfi60977f0i4k9x1zj68lrvpzzlqndz8cgh9"))
+       (file-name (git-file-name name version))))
+    (build-system meson-build-system)
+    (native-inputs (list pkg-config
+                         (list glib "bin")))
+    (synopsis "Automatic theme switcher for GNOME Shell")
+    (description
+     "Automatically toggle your GNOME desktop’s color scheme between light and
+dark, switch backgrounds and run custom commands at sunset and sunrise.")
+    (home-page "https://nightthemeswitcher.romainvigier.fr")
+    (license license:gpl2+)))
+
 (define-public gpaste
   (package
     (name "gpaste")