diff mbox series

[bug#64933,v2] gnu: Add dexy-color-sddm-theme.

Message ID DU2P193MB2132BC650D1C8D1BF6855463F3F9A@DU2P193MB2132.EURP193.PROD.OUTLOOK.COM
State New
Headers show
Series [bug#64933,v2] gnu: Add dexy-color-sddm-theme. | expand

Commit Message

Sergio Pastor Pérez Sept. 20, 2023, 9:27 p.m. UTC
* gnu/packages/display-managers.scm (dexy-color-sddm-theme): New variable.
---
 gnu/packages/display-managers.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)


base-commit: 4bdb8bd2674c2b630626be43a5cd3c2b65401b52

Comments

Ludovic Courtès Oct. 14, 2023, 3:32 p.m. UTC | #1
Sergio Pastor Pérez <sergio.pastorperez@outlook.es> skribis:

> * gnu/packages/display-managers.scm (dexy-color-sddm-theme): New variable.

Applied, thanks!
diff mbox series

Patch

diff --git a/gnu/packages/display-managers.scm b/gnu/packages/display-managers.scm
index 327a29aa9e..ef9826c0f7 100644
--- a/gnu/packages/display-managers.scm
+++ b/gnu/packages/display-managers.scm
@@ -142,6 +142,32 @@  (define-public sddm
     ;; QML files are MIT licensed and images are CC BY 3.0.
     (license (list license:gpl2+ license:expat license:cc-by3.0))))
 
+(define-public dexy-color-sddm-theme
+  (let ((commit "7929384dbb9305e6da53a8942bca3d75593fd99f")
+        (revision "0"))
+    (package
+      (name "dexy-color-sddm-theme")
+      (version (git-version "0.0.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/L4ki/Dexy-Plasma-Themes")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "1dcp3pvs6x63740sz852yr19fjrdnh81dbrq7rssgm6ssi1rqjig"))))
+      (build-system copy-build-system)
+      (arguments
+       `(#:install-plan '(("Dexy-Color-SDDM"
+                           "/share/sddm/themes/dexy-color-sddm"))))
+      (home-page "https://github.com/L4ki/Dexy-Plasma-Themes")
+      (synopsis "Dexy Color theme for SDDM")
+      (description
+       "This package provides a minimalistic and modern SDDM theme with blured
+background.")
+      (license license:gpl3+))))
+
 (define-public guix-simplyblack-sddm-theme
   (package
     (name "guix-simplyblack-sddm-theme")