diff mbox series

[bug#64932,v2] gnu: Add abstractdark-sddm-theme.

Message ID DU2P193MB2132BB998401BE3CDED510C0F3F9A@DU2P193MB2132.EURP193.PROD.OUTLOOK.COM
State New
Headers show
Series [bug#64932,v2] gnu: Add abstractdark-sddm-theme. | expand

Commit Message

Sergio Pastor Pérez Sept. 20, 2023, 9:30 p.m. UTC
* gnu/packages/display-managers.scm (abstractdark-sddm-theme): New variable.
---
Hi.

Here you have the corrections you've asked. I've sent you another mail with the
changes for the dexy-color-sddm-theme.

Good night,
Sergio.

 gnu/packages/display-managers.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)


base-commit: 4bdb8bd2674c2b630626be43a5cd3c2b65401b52
prerequisite-patch-id: 5c871c0f03698adb5cbf1aa075bfce296029bc03

Comments

Ludovic Courtès Oct. 14, 2023, 3:30 p.m. UTC | #1
HI,

Sergio Pastor Pérez <sergio.pastorperez@outlook.es> skribis:

> * gnu/packages/display-managers.scm (abstractdark-sddm-theme): New variable.
> ---
> Hi.
>
> Here you have the corrections you've asked. I've sent you another mail with the
> changes for the dexy-color-sddm-theme.

I had to add #:use-module (guix build-system copy).  Applied with this
change.

Thanks,
Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/display-managers.scm b/gnu/packages/display-managers.scm
index ef9826c0f7..ba9e26142e 100644
--- a/gnu/packages/display-managers.scm
+++ b/gnu/packages/display-managers.scm
@@ -168,6 +168,31 @@  (define-public dexy-color-sddm-theme
 background.")
       (license license:gpl3+))))
 
+(define-public abstractdark-sddm-theme
+  (let ((commit "e817d4b27981080cd3b398fe928619ffa16c52e7")
+        (revision "0"))
+    (package
+      (name "abstractdark-sddm-theme")
+      (version (git-version "0.0.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/3ximus/abstractdark-sddm-theme")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "1si141hnp4lr43q36mbl3anlx0a81r8nqlahz3n3l7zmrxb56s2y"))))
+      (build-system copy-build-system)
+      (arguments
+       `(#:install-plan '(("." "/share/sddm/themes/abstractdark"))))
+      (home-page "https://github.com/3ximus/abstractdark-sddm-theme")
+      (synopsis "Abstract Dark theme for SDDM")
+      (description
+       "This package provides a minimalistic dark theme for SDDM, black
+background with abstract shapes. Inspired by solarized-sddm-theme.")
+      (license license:gpl3+))))
+
 (define-public guix-simplyblack-sddm-theme
   (package
     (name "guix-simplyblack-sddm-theme")