diff mbox series

[bug#64957,v3] gnu: Add fontmake.

Message ID DU2P193MB2132B875AD4B8F9AF87277E5F305A@DU2P193MB2132.EURP193.PROD.OUTLOOK.COM
State New
Headers show
Series [bug#64957,v3] gnu: Add fontmake. | expand

Commit Message

Sergio Pastor Pérez July 31, 2023, 8:29 a.m. UTC
* gnu/packages/fontutils.scm (fontmake): New variable.
---
Good morning Hilton.

Here you have the changes applied. I've reduced the `inputs' field to
`python-fontmath' and `python-glyphslib'. Also, the personal sentence has been
changed to impersonal tense.

 gnu/packages/fontutils.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)


base-commit: c173819c8e5235ce02d60b79bd88b10023a7c614
prerequisite-patch-id: c56db9fa7fc4e07452dea53f2d450bd83abbbc1a
prerequisite-patch-id: 3e6318d61f2efa01f4435152f2139eef8f72572c
prerequisite-patch-id: 1b23c59bab92820a1e102137909922f4d71ed8f9
prerequisite-patch-id: 78a291411f8d86beabbf6d49df0cc78702ad4e65
prerequisite-patch-id: 579224b39cae7869ce11e2e8dba046b5eef606c7
prerequisite-patch-id: f1f62fd5d83d603ca35c17071e615352e90753e3
prerequisite-patch-id: 1843bca37f83e494be67c24e975727fb1fe1248c
prerequisite-patch-id: 5cc0d6cd16ae2ab21c444ed9cabfeea5615e8cda
prerequisite-patch-id: 92a3fab6e4174a4d4877fc5b426752df81e4df39
prerequisite-patch-id: ebf3fd3a8bb02f7dc5cdf504f63d5028b29fe69e

Comments

Hilton Chain July 31, 2023, 4:39 p.m. UTC | #1
On Mon, 31 Jul 2023 16:29:34 +0800,
Sergio Pastor Pérez wrote:
>
> * gnu/packages/fontutils.scm (fontmake): New variable.
> ---
> Good morning Hilton.
>
> Here you have the changes applied. I've reduced the `inputs' field to
> `python-fontmath' and `python-glyphslib'. Also, the personal sentence has been
> changed to impersonal tense.
>
>  gnu/packages/fontutils.scm | 23 +++++++++++++++++++++++
>  1 file changed, 23 insertions(+)
>
> diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
> index 153602b4b4..9a65538599 100644
> --- a/gnu/packages/fontutils.scm
> +++ b/gnu/packages/fontutils.scm
> @@ -776,6 +776,29 @@ (define-public psautohint-font-data
>         ;; Code Pro, Source Serif Pro, all available under the same license.
>         (license license:silofl1.1)))))
>
> +(define-public fontmake
> +  (package
> +    (name "fontmake")
> +    (version "3.4.0")
> +    (source (origin
> +              (method url-fetch)
> +              (uri (pypi-uri "fontmake" version ".zip"))
> +              (sha256
> +               (base32
> +                "0fc5c9csjpy1aa4c03p7nvjgls5wjplhmmf42n0cmvrlh6cm7wl3"))))
> +    (build-system python-build-system)
> +    (inputs (list python-fontmath
> +                  python-glyphslib))
> +    (native-inputs (list unzip python-setuptools-scm))
> +    (home-page "https://github.com/googlefonts/fontmake")
> +    (synopsis
> +     "Compile fonts from sources (UFO, Glyphs) to binary (OpenType, TrueType)")
> +    (description
> +     "Fontmake compiles fonts from various sources (.glyphs, .ufo,designspace)
> +into binaries (.otf, .ttf).  It can be used to create static instances and
> +variable fonts.")
> +    (license license:asl2.0)))


I mentioned the description in V2, but you might not notice it.

Synopsis and description use TexInfo format and @code{...} can be seen
as `...` in Markdown, you can run `./pre-inst-env guix show fontmake'
to see if it's displayed correctly.

--8<---------------cut here---------------start------------->8---
     "Fontmake compiles fonts from various sources (@code{.glyphs}, @code{.ufo},
@code{designspace}) into binaries (@code{.otf}, @code{.ttf}).  It can be used to
create static instances and variable fonts."
--8<---------------cut here---------------end--------------->8---

I have sent a patch to update python-attrs[1], I'll ping you once it's
available in master.

Thanks

[1] <https://issues.guix.gnu.org/64973>
diff mbox series

Patch

diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index 153602b4b4..9a65538599 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -776,6 +776,29 @@  (define-public psautohint-font-data
        ;; Code Pro, Source Serif Pro, all available under the same license.
        (license license:silofl1.1)))))
 
+(define-public fontmake
+  (package
+    (name "fontmake")
+    (version "3.4.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "fontmake" version ".zip"))
+              (sha256
+               (base32
+                "0fc5c9csjpy1aa4c03p7nvjgls5wjplhmmf42n0cmvrlh6cm7wl3"))))
+    (build-system python-build-system)
+    (inputs (list python-fontmath
+                  python-glyphslib))
+    (native-inputs (list unzip python-setuptools-scm))
+    (home-page "https://github.com/googlefonts/fontmake")
+    (synopsis
+     "Compile fonts from sources (UFO, Glyphs) to binary (OpenType, TrueType)")
+    (description
+     "Fontmake compiles fonts from various sources (.glyphs, .ufo,designspace)
+into binaries (.otf, .ttf).  It can be used to create static instances and
+variable fonts.")
+    (license license:asl2.0)))
+
 (define-public psautohint
   (package
     (name "psautohint")