diff mbox series

[bug#64957,v4] gnu: Add fontmake.

Message ID DU2P193MB2132A3819110619AB4C45D77F30AA@DU2P193MB2132.EURP193.PROD.OUTLOOK.COM
State New
Headers show
Series [bug#64957,v4] gnu: Add fontmake. | expand

Commit Message

Sergio Pastor Pérez Aug. 1, 2023, 7:05 a.m. UTC
* gnu/packages/fontutils.scm (fontmake): New variable.
---
Good morning Hilton,

I had missed the markdown suggestion from V2. Here you have the format
corrected. I will wait for the update of `python-attrs'.

Have a nice day.

 gnu/packages/fontutils.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)


base-commit: 55e89da207b95230e5f2a8176acd9cc9b43971ff
prerequisite-patch-id: c56db9fa7fc4e07452dea53f2d450bd83abbbc1a
prerequisite-patch-id: 3e6318d61f2efa01f4435152f2139eef8f72572c
prerequisite-patch-id: 1b23c59bab92820a1e102137909922f4d71ed8f9
prerequisite-patch-id: 78a291411f8d86beabbf6d49df0cc78702ad4e65
prerequisite-patch-id: 579224b39cae7869ce11e2e8dba046b5eef606c7
prerequisite-patch-id: f1f62fd5d83d603ca35c17071e615352e90753e3
prerequisite-patch-id: 1843bca37f83e494be67c24e975727fb1fe1248c
prerequisite-patch-id: 5cc0d6cd16ae2ab21c444ed9cabfeea5615e8cda
prerequisite-patch-id: 92a3fab6e4174a4d4877fc5b426752df81e4df39
prerequisite-patch-id: ebf3fd3a8bb02f7dc5cdf504f63d5028b29fe69e

Comments

Maxim Cournoyer Sept. 6, 2023, 4:52 a.m. UTC | #1
Hi,

Sergio Pastor Pérez <sergio.pastorperez@outlook.es> writes:

> * gnu/packages/fontutils.scm (fontmake): New variable.

Installed!
diff mbox series

Patch

diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index 153602b4b4..3ee3dc76ab 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -776,6 +776,28 @@  (define-public psautohint-font-data
        ;; Code Pro, Source Serif Pro, all available under the same license.
        (license license:silofl1.1)))))
 
+(define-public fontmake
+  (package
+    (name "fontmake")
+    (version "3.4.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "fontmake" version ".zip"))
+              (sha256
+               (base32
+                "0fc5c9csjpy1aa4c03p7nvjgls5wjplhmmf42n0cmvrlh6cm7wl3"))))
+    (build-system python-build-system)
+    (inputs (list python-fontmath python-glyphslib))
+    (native-inputs (list unzip python-setuptools-scm))
+    (home-page "https://github.com/googlefonts/fontmake")
+    (synopsis
+     "Compile fonts from sources (UFO, Glyphs) to binary (OpenType, TrueType)")
+    (description
+     "Fontmake compiles fonts from various sources (@code{.glyphs}, @code{.ufo},
+@code{designspace}) into binaries (@code{.otf}, @code{.ttf}).  It can be used to
+create static instances and variable fonts.")
+    (license license:asl2.0)))
+
 (define-public psautohint
   (package
     (name "psautohint")