diff mbox series

[bug#64933] gnu: Add dexy-color-sddm-theme.

Message ID DU2P193MB2132603FFB6D8546B11120E0F307A@DU2P193MB2132.EURP193.PROD.OUTLOOK.COM
State New
Headers show
Series [bug#64933] gnu: Add dexy-color-sddm-theme. | expand

Commit Message

Sergio Pastor Pérez July 29, 2023, 1:02 p.m. UTC
* gnu/packages/display-managers.scm (dexy-color-sddm-theme): New variable.
---
 gnu/packages/display-managers.scm | 35 +++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)


base-commit: e43cbeafd1b632f39b08b3644af5230d5350a656

Comments

Ludovic Courtès Sept. 17, 2023, 1:13 p.m. UTC | #1
Hi,

And apologies for the late reply.

Sergio Pastor Pérez <sergio.pastorperez@outlook.es> skribis:

> * gnu/packages/display-managers.scm (dexy-color-sddm-theme): New variable.

[...]

> +      (build-system trivial-build-system)
> +      (arguments
> +       `(#:modules ((guix build utils))
> +         #:builder (begin
> +                     (use-modules (guix build utils))
> +                     (let* ((out (assoc-ref %outputs "out"))
> +                            (sddm-themes (string-append out
> +                                                        "/share/sddm/themes")))
> +                       (mkdir-p sddm-themes)
> +                       (copy-recursively (string-append (assoc-ref
> +                                                         %build-inputs
> +                                                         "source")
> +                                                        "/Dexy-Color-SDDM")
> +                                         (string-append sddm-themes
> +                                                        "/dexy-color"))))))

Could you consider writing it using ‘copy-build-system’?  It should lead
to a more concise definition.

> +      (home-page "https://github.com/L4ki/Dexy-Plasma-Themes")
> +      (synopsis "Dexy Color theme for SDDM")
> +      (description "Dexy-Color-SDDM is part of KDE Themes and Extensions.")

It would be great if you could add a sentence saying what the package
provides (think about someone running ‘guix search’ and not knowing
which package might provide the thing).

Could you send an updated patch?

Thanks in advance,
Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/display-managers.scm b/gnu/packages/display-managers.scm
index f6c9283a29..dcfa3bcf3f 100644
--- a/gnu/packages/display-managers.scm
+++ b/gnu/packages/display-managers.scm
@@ -142,6 +142,41 @@  (define-public sddm
     ;; QML files are MIT licensed and images are CC BY 3.0.
     (license (list license:gpl2+ license:expat license:cc-by3.0))))
 
+(define-public dexy-color-sddm-theme
+  (let ((commit "7929384dbb9305e6da53a8942bca3d75593fd99f")
+        (revision "0"))
+    (package
+      (name "dexy-color-sddm-theme")
+      (version (git-version "0.0.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/L4ki/Dexy-Plasma-Themes")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "1dcp3pvs6x63740sz852yr19fjrdnh81dbrq7rssgm6ssi1rqjig"))))
+      (build-system trivial-build-system)
+      (arguments
+       `(#:modules ((guix build utils))
+         #:builder (begin
+                     (use-modules (guix build utils))
+                     (let* ((out (assoc-ref %outputs "out"))
+                            (sddm-themes (string-append out
+                                                        "/share/sddm/themes")))
+                       (mkdir-p sddm-themes)
+                       (copy-recursively (string-append (assoc-ref
+                                                         %build-inputs
+                                                         "source")
+                                                        "/Dexy-Color-SDDM")
+                                         (string-append sddm-themes
+                                                        "/dexy-color"))))))
+      (home-page "https://github.com/L4ki/Dexy-Plasma-Themes")
+      (synopsis "Dexy Color theme for SDDM")
+      (description "Dexy-Color-SDDM is part of KDE Themes and Extensions.")
+      (license license:gpl3+))))
+
 (define-public guix-simplyblack-sddm-theme
   (package
     (name "guix-simplyblack-sddm-theme")