diff mbox series

[bug#64951] gnu: Add font-stix-two.

Message ID DU2P193MB213239E3FF445D9924BC75EAF304A@DU2P193MB2132.EURP193.PROD.OUTLOOK.COM
State New
Headers show
Series [bug#64951] gnu: Add font-stix-two. | expand

Commit Message

Sergio Pastor PĂ©rez July 30, 2023, 11:11 a.m. UTC
* gnu/packages/fonts.scm (font-stix-two): New variable.
---
 gnu/packages/fonts.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)


base-commit: c173819c8e5235ce02d60b79bd88b10023a7c614
prerequisite-patch-id: c56db9fa7fc4e07452dea53f2d450bd83abbbc1a
prerequisite-patch-id: 3e6318d61f2efa01f4435152f2139eef8f72572c
prerequisite-patch-id: 1b23c59bab92820a1e102137909922f4d71ed8f9
prerequisite-patch-id: 78a291411f8d86beabbf6d49df0cc78702ad4e65
prerequisite-patch-id: 579224b39cae7869ce11e2e8dba046b5eef606c7
prerequisite-patch-id: f1f62fd5d83d603ca35c17071e615352e90753e3
diff mbox series

Patch

diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 2a87679739..9786231805 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -3397,3 +3397,24 @@  (define-public font-iosevka-comfy
     (description
      "Iosevka Comfy is a customised build of the Iosevka typeface, with a consistent rounded style and overrides for almost all individual glyphs in both roman (upright) and italic (slanted) variants.")
     (license license:silofl1.1)))
+
+(define-public font-stix-two
+  (package
+    (name "font-stix-two")
+    (version "v2.13b171")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://codeload.github.com/stipub/stixfonts/tar.gz/refs/tags/"
+                    version))
+              (file-name (string-append name version ".tar.gz"))
+              (sha256
+               (base32
+                "0zwlkhxkq88yzs1lpkhzil2yjq3227cmhnxdfgzp50xh1fmvjxhy"))))
+    (build-system font-build-system)
+    (home-page "https://www.stixfonts.org/")
+    (synopsis
+     "OpenType Unicode fonts for Scientific, Technical, and Mathematical texts")
+    (description
+     "The mission of the Scientific and Technical Information Exchange (STIX) font creation project is the preparation of a comprehensive set of fonts that serve the scientific and engineering community in the process from manuscript creation through final publication, both in electronic and print formats.")
+    (license license:silofl1.1)))