diff mbox series

[bug#65011,v1] gnu: Add xwinwrap.

Message ID DU2P193MB21321446ED93573C1B7397ADF3E8A@DU2P193MB2132.EURP193.PROD.OUTLOOK.COM
State New
Headers show
Series [bug#65011,v1] gnu: Add xwinwrap. | expand

Commit Message

Sergio Pastor PĂ©rez Sept. 5, 2023, 5:07 p.m. UTC
* gnu/packages/xdisorg.scm (xwinwrap): New variable.
---
Good evening Jean Pierre.

Here you hace the revised patch.

Excuse me for the late reply. Greetings.

 gnu/packages/xdisorg.scm | 37 +++++++++++++++++++++++++++++++++++++
 1 file changed, 37 insertions(+)


base-commit: 3d58f22c053388f7805d9cc462d2b18fb28798da
diff mbox series

Patch

diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index da5ca76e10..da1bc16551 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -3301,6 +3301,43 @@  (define-public jumpapp
     (home-page "https://github.com/mkropat/jumpapp")
     (license license:expat)))
 
+(define-public xwinwrap
+  (let ((revision "0")
+        (commit "ec32e9b72539de7e1553a4f70345166107b431f7"))
+    (package
+      (name "xwinwrap")
+      (version (git-version "0.0.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/r00tdaemon/xwinwrap")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "0l3ng6w8jl9mryk5nx61qpd1bv5yqm7cnwy2s3vcy88n04ggbap9"))))
+      (build-system gnu-build-system)
+      (inputs (list libx11 libxrender libxext))
+      (arguments
+       (list #:tests? #f ; No tests.
+             #:phases #~(modify-phases %standard-phases
+                          (add-after 'unpack 'fix-hardcoded-paths
+                            (lambda _
+                              (substitute* "Makefile"
+                                (("/usr/local")
+                                 %output))))
+                          (delete 'configure)
+                          (add-before 'install 'create-missing-dirs
+                            (lambda _
+                              (mkdir-p (string-append #$output "/bin")))))))
+      (home-page "https://github.com/r00tdaemon/xwinwrap")
+      (synopsis
+       "X utility that allows sticking most of apps to a desktop background")
+      (description
+       "Fork of xwinwrap.  Xwinwrap allows you to stick most of the apps to
+your desktop background.")
+      (license license:gpl3+))))
+
 (define-public xkbset
   (package
     (name "xkbset")