diff mbox series

[bug#64932] gnu: Add abstract-sddm-theme.

Message ID DU2P193MB213205400BEA682070A3880CF307A@DU2P193MB2132.EURP193.PROD.OUTLOOK.COM
State New
Headers show
Series [bug#64932] gnu: Add abstract-sddm-theme. | expand

Commit Message

Sergio Pastor Pérez July 29, 2023, 12:50 p.m. UTC
* gnu/packages/display-managers.scm (abstract-sddm-theme): New variable.
---
 gnu/packages/display-managers.scm | 33 +++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)


base-commit: e43cbeafd1b632f39b08b3644af5230d5350a656
prerequisite-patch-id: c56db9fa7fc4e07452dea53f2d450bd83abbbc1a

Comments

Ludovic Courtès Sept. 17, 2023, 1:15 p.m. UTC | #1
Sergio Pastor Pérez <sergio.pastorperez@outlook.es> skribis:

> * gnu/packages/display-managers.scm (abstract-sddm-theme): New variable.

[...]

> +      (build-system trivial-build-system)
> +      (arguments
> +       `(#:modules ((guix build utils))
> +         #:builder (begin
> +                     (use-modules (guix build utils))
> +                     (let* ((out (assoc-ref %outputs "out"))
> +                            (sddm-themes (string-append out
> +                                                        "/share/sddm/themes")))
> +                       (mkdir-p sddm-themes)
> +                       (copy-recursively (assoc-ref %build-inputs "source")
> +                                         (string-append sddm-themes
> +                                                        "/abstract"))))))
> +      (home-page "https://github.com/3ximus/abstractdark-sddm-theme")
> +      (synopsis "Abstract Dark theme for SDDM")
> +      (description
> +       "This package provides a simple theme for SDDM inspired by solarized-sddm-theme.")

Same suggestions as for dexy-color-sddm-theme.  :-)

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/display-managers.scm b/gnu/packages/display-managers.scm
index dcfa3bcf3f..f33889d23d 100644
--- a/gnu/packages/display-managers.scm
+++ b/gnu/packages/display-managers.scm
@@ -177,6 +177,39 @@  (define-public dexy-color-sddm-theme
       (description "Dexy-Color-SDDM is part of KDE Themes and Extensions.")
       (license license:gpl3+))))
 
+(define-public abstract-sddm-theme
+  (let ((commit "e817d4b27981080cd3b398fe928619ffa16c52e7")
+        (revision "0"))
+    (package
+      (name "abstract-sddm-theme")
+      (version (git-version "0.0.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/3ximus/abstractdark-sddm-theme")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "1si141hnp4lr43q36mbl3anlx0a81r8nqlahz3n3l7zmrxb56s2y"))))
+      (build-system trivial-build-system)
+      (arguments
+       `(#:modules ((guix build utils))
+         #:builder (begin
+                     (use-modules (guix build utils))
+                     (let* ((out (assoc-ref %outputs "out"))
+                            (sddm-themes (string-append out
+                                                        "/share/sddm/themes")))
+                       (mkdir-p sddm-themes)
+                       (copy-recursively (assoc-ref %build-inputs "source")
+                                         (string-append sddm-themes
+                                                        "/abstract"))))))
+      (home-page "https://github.com/3ximus/abstractdark-sddm-theme")
+      (synopsis "Abstract Dark theme for SDDM")
+      (description
+       "This package provides a simple theme for SDDM inspired by solarized-sddm-theme.")
+      (license license:gpl3+))))
+
 (define-public guix-simplyblack-sddm-theme
   (package
     (name "guix-simplyblack-sddm-theme")