diff mbox series

[bug#52113] gnu: Add pnmixer

Message ID DM6PR19MB24607D4AC755449D3F4C3AC799629@DM6PR19MB2460.namprd19.prod.outlook.com
State Accepted
Headers show
Series [bug#52113] gnu: Add pnmixer | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Wamm K. D Nov. 25, 2021, 7:48 p.m. UTC
* gnu/packages/gtk.scm (pnmixer):Add PNMixer
---
gnu/packages/gtk.scm | 39 +++++++++++++++++++++++++++++++++++++++
1 file changed, 39 insertions(+)

Comments

Nicolas Goaziou Dec. 5, 2021, 8:43 p.m. UTC | #1
Hello,

Jaft <jaft.r@outlook.com> writes:

> * gnu/packages/gtk.scm (pnmixer):Add PNMixer

Thank you. Some comments follow.

> +(define-public pnmixer
> +  (let ([version "0.7.2"])

Nitpick: we don't use square brackets for let. Besides, you do not need
a binding here, you just need to hard-code it in the version field.

> +    (package
> +      (name "pnmixer")
> +      (version version)
> +      (source (origin

Could you move origin below source?

> +                (method git-fetch)
> +                (uri (git-reference
> +                      (url "https://github.com/nicklan/pnmixer/")
> +                      (commit (string-append "v" version))))
> +                (file-name (git-file-name name version))
> +                (sha256 (base32
> +                         "0416pa933ddf4b7ph9zxhk5jppkk7ppcq1aqph6xsrfnka4yb148"))

Could you move base32 below sha256 and put the hash string in front of base32?

> +                (modules '((guix build utils)))))

The modules part is not required. You can remove it.

> +    (build-system cmake-build-system)
> +    (arguments `(#:phases (modify-phases %standard-phases (delete 'check))))

The correct way to do this is to add a "#:tests? #f" argument, with
a comment explaining why you are disabling tests.

> +    (native-inputs `(("pkg-config" ,pkg-config)
> +                     ("gettext" ,gettext-minimal)))

Native inputs should be ordered alphabetically. Besides, the list should
be moved on the line below native-inputs.

> +    (inputs `(("alsa-lib" ,alsa-lib)
> +              ("glib" ,glib)
> +              ("libx11" ,libx11)
> +              ("gtk+" ,gtk+)
> +              ("libnotify" ,libnotify)))

Ditto: please order inputs alphabetically and move them below the inputs
field name.

> +    (home-page "https://github.com/nicklan/pnmixer/")
> +    (synopsis "Simple mixer application designed to run in your system tray")

Nitpick: you can remove "your" in the synopsis

Could you send an updated patch?

Regards,
-- 
Nicolas Goaziou
diff mbox series

Patch

diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 4e427deaef..782dfebdb2 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -27,6 +27,7 @@ 
 ;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2021 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2021 Simon Streit <simon@netpanic.org>
+;;; Copyright © 2021 Wamm K. D. <jaft.r@outlook.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -50,6 +51,7 @@  (define-module (gnu packages gtk)
   #:use-module (guix download)
   #:use-module (guix git-download)
   #:use-module ((guix build utils) #:select (alist-replace))
+  #:use-module (guix build-system cmake)
   #:use-module (guix build-system glib-or-gtk)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system meson)
@@ -2474,3 +2476,40 @@  (define-public volctl
     ;; XXX: 'setup.py' says "GPLv2" but nothing says "version 2 only".  Is
     ;; GPLv2+ intended?
     (license license:gpl2)))
+
+(define-public pnmixer
+  (let ([version "0.7.2"])
+    (package
+      (name "pnmixer")
+      (version version)
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/nicklan/pnmixer/")
+                      (commit (string-append "v" version))))
+                (file-name (git-file-name name version))
+                (sha256 (base32
+                         "0416pa933ddf4b7ph9zxhk5jppkk7ppcq1aqph6xsrfnka4yb148"))
+                (modules '((guix build utils)))))
+    (build-system cmake-build-system)
+    (arguments `(#:phases (modify-phases %standard-phases (delete 'check))))
+    (native-inputs `(("pkg-config" ,pkg-config)
+                     ("gettext" ,gettext-minimal)))
+    (inputs `(("alsa-lib" ,alsa-lib)
+              ("glib" ,glib)
+              ("libx11" ,libx11)
+              ("gtk+" ,gtk+)
+              ("libnotify" ,libnotify)))
+    (home-page "https://github.com/nicklan/pnmixer/")
+    (synopsis "Simple mixer application designed to run in your system tray")
+    (description "PNMixer is a simple mixer application designed to run in your
+system tray.  It integrates nicely into desktop environments that don't have a
+panel that supports applets and therefore can't run a mixer applet.  In
+particular, it's been used quite a lot with fbpanel and tint2 but should run
+fine in any system tray.
+
+PNMixer is designed to work on systems that use ALSA for sound management.  Any
+other sound driver like OSS or FFADO are, currently, not supported.  There is no
+official PulseAudio support, at the moment, but it seems that PNMixer behaves
+quite well anyway when PA is running.")
+    (license license:gpl3))))