diff mbox series

[bug#51967] package: calendar: Add gsimplecal to Guix

Message ID DM6PR19MB246052DFA5B76FDB4CA2F2DD999C9@DM6PR19MB2460.namprd19.prod.outlook.com
State Accepted
Headers show
Series [bug#51967] package: calendar: Add gsimplecal to Guix | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Wamm K. D Nov. 19, 2021, 8:48 a.m. UTC
Hello; this is my first patch so, if I've missed or forgotten anything, just let me know and I'm happy to get it fixed.
As per the subject, this patch merely adds gsimplecal as a package; calendar seemed like the most sensible category to slot it under as it's, in fact, a calendar, I figured.
Thanks!


* gnu/packages/calendar.scm (gsimplecal): Add gsimplecal to Guix for the first time, sourced from git.---gnu/packages/calendar.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

diff --git a/gnu/packages/calendar.scm b/gnu/packages/calendar.scmindex 8ec36d4fa2..4c54ac0549 100644--- a/gnu/packages/calendar.scm+++ b/gnu/packages/calendar.scm@@ -10,6 +10,7 @@ ;;; Copyright © 2020 Brendan Tildesley <mail@brendan.scot> ;;; Copyright © 2020 Tanguy Le Carrour <tanguy@bioneland.org> ;;; Copyright © 2020 Peng Mei Yu <pengmeiyu@riseup.net>+;;; Copyright © 2021 Wamm K. D. <jaft.r@outlook.com> ;;; ;;; This file is part of GNU Guix. ;;;@@ -36,6 +37,7 @@ (define-module (gnu packages calendar)   #:use-module (guix build-system cmake)   #:use-module (guix build-system python)   #:use-module (gnu packages admin)+  #:use-module (gnu packages autotools)   #:use-module (gnu packages base)   #:use-module (gnu packages check)   #:use-module (gnu packages dav)@@ -405,3 +407,31 @@ (define-public ccal     ;; COPYING.LESSER specifies LGPL 3.0, but all source files say     ;; 'Lesser GPL version 2 or later'.     (license (list license:gpl2+ license:lgpl2.1+))))++(define-public gsimplecal+  (let ([commit   "f00b80d86300397b52c3cf7d8dfc8de5cdee921d"]+        [revision                                        "1"])+    (package+      (name          "gsimplecal")+      (version       (git-version "2.2" revision commit))+      (source        (origin+                       (method    git-fetch)+                       (uri       (git-reference+                                   (url    "https://github.com/dmedvinsky/gsimplecal/")+                                   (commit                                      commit)))+                       (file-name (git-file-name name version))+                       (sha256    (base32 (string-append/shared+                                           "1qyf65l088dqsz25hm6s1cv18j"+                                           "52yaias0llqvpqwjfnvssa5cxg")))+                       (modules   '((guix build utils)))))+      (build-system  gnu-build-system)+      (native-inputs `(("autoconf"     ,autoconf)+                       ("automake"     ,automake)+                       ("pkg-config" ,pkg-config)+                       ("gtk+"             ,gtk+)))+      (home-page     "https://dmedvinsky.github.io/gsimplecal/")+      (synopsis      "Lightweight calendar applet written in C++ using GTK")+      (description   "Gsimplecal was intentionally made for use with tint2 panel+in the openbox environment to be launched upon clock click but, of course, it+will work without it.")+      (license       license:bsd-3))))

Comments

Liliana Marie Prikler Nov. 19, 2021, 7:55 p.m. UTC | #1
Hi,

Am Freitag, den 19.11.2021, 08:48 +0000 schrieb Jaft:
> Hello; this is my first patch so, if I've missed or forgotten
> anything, just let me know and I'm happy to get it fixed.
First things first: transmit plain text, not HTML.

Second, only the topmost directory (gnu:, guix:, doc:) is usually
important.  Package additions follow the rule "gnu: Add PACKAGE".

> * gnu/packages/calendar.scm (gsimplecal): Add gsimplecal to Guix for
> the first time, sourced from git.
Simply say "New variable".

> ---
This line marks where you can add comments when you transmit the patch
as-is.  You might want to use it in lieu of a pre-statement.

> gnu/packages/calendar.scm | 30 ++++++++++++++++++++++++++++++
> 1 file changed, 30 insertions(+)
> 
> diff --git a/gnu/packages/calendar.scm b/gnu/packages/calendar.scm
> index 8ec36d4fa2..4c54ac0549 100644
> --- a/gnu/packages/calendar.scm
> +++ b/gnu/packages/calendar.scm
> @@ -10,6 +10,7 @@
>  ;;; Copyright © 2020 Brendan Tildesley <mail@brendan.scot>
>  ;;; Copyright © 2020 Tanguy Le Carrour <tanguy@bioneland.org>
>  ;;; Copyright © 2020 Peng Mei Yu <pengmeiyu@riseup.net>
> +;;; Copyright © 2021 Wamm K. D. <jaft.r@outlook.com>
>  ;;;
>  ;;; This file is part of GNU Guix.
>  ;;;
> @@ -36,6 +37,7 @@ (define-module (gnu packages calendar)
>    #:use-module (guix build-system cmake)
>    #:use-module (guix build-system python)
>    #:use-module (gnu packages admin)
> +  #:use-module (gnu packages autotools)
>    #:use-module (gnu packages base)
>    #:use-module (gnu packages check)
>    #:use-module (gnu packages dav)
> @@ -405,3 +407,31 @@ (define-public ccal
>      ;; COPYING.LESSER specifies LGPL 3.0, but all source files say
>      ;; 'Lesser GPL version 2 or later'.
>      (license (list license:gpl2+ license:lgpl2.1+))))
> +
> +(define-public gsimplecal
> +  (let ([commit   "f00b80d86300397b52c3cf7d8dfc8de5cdee921d"]
> +        [revision                                        "1"])
Guile is not racket, it's round brackets everywhere.
We also don't do right alignment.  A simple space between
variable/field and value is enough.
> +    (package
> +      (name          "gsimplecal")
As above, pp.
> +      (version       (git-version "2.2" revision commit))
> +      (source        (origin
> +                       (method    git-fetch)
> +                       (uri       (git-reference
> +                                   (url    "
> https://github.com/dmedvinsky/gsimplecal/")
> +                                   (commit                         
>             commit)))
> +                       (file-name (git-file-name name version))
> +                       (sha256    (base32 (string-append/shared
> +                                         
>  "1qyf65l088dqsz25hm6s1cv18j"
> +                                         
>  "52yaias0llqvpqwjfnvssa5cxg")))
Use a single string rather than a function call.
> +                       (modules   '((guix build utils)))))
> +      (build-system  gnu-build-system)
> +      (native-inputs `(("autoconf"     ,autoconf)
> +                       ("automake"     ,automake)
> +                       ("pkg-config" ,pkg-config)
> +                       ("gtk+"             ,gtk+)))
GTK+ is probably not a native-input.  Also use a newline here.
> +      (home-page     "https://dmedvinsky.github.io/gsimplecal/")
> +      (synopsis      "Lightweight calendar applet written in C++
> using GTK")
> +      (description   "Gsimplecal was intentionally made for use with
> tint2 panel
> +in the openbox environment to be launched upon clock click but, of
> course, it
> +will work without it.")
That's... not very descriptive, is it?
> +      (license       license:bsd-3))))

Thanks for the submission and happy hacking :)
diff mbox series

Patch

diff --git a/gnu/packages/calendar.scm b/gnu/packages/calendar.scm
index 8ec36d4fa2..4c54ac0549 100644
--- a/gnu/packages/calendar.scm
+++ b/gnu/packages/calendar.scm
@@ -10,6 +10,7 @@ 
 ;;; Copyright © 2020 Brendan Tildesley <mail@brendan.scot>
 ;;; Copyright © 2020 Tanguy Le Carrour <tanguy@bioneland.org>
 ;;; Copyright © 2020 Peng Mei Yu <pengmeiyu@riseup.net>
+;;; Copyright © 2021 Wamm K. D. <jaft.r@outlook.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -36,6 +37,7 @@  (define-module (gnu packages calendar)
   #:use-module (guix build-system cmake)
   #:use-module (guix build-system python)
   #:use-module (gnu packages admin)
+  #:use-module (gnu packages autotools)
   #:use-module (gnu packages base)
   #:use-module (gnu packages check)
   #:use-module (gnu packages dav)
@@ -405,3 +407,31 @@  (define-public ccal
     ;; COPYING.LESSER specifies LGPL 3.0, but all source files say
     ;; 'Lesser GPL version 2 or later'.
     (license (list license:gpl2+ license:lgpl2.1+))))
+
+(define-public gsimplecal
+  (let ([commit   "f00b80d86300397b52c3cf7d8dfc8de5cdee921d"]
+        [revision                                        "1"])
+    (package
+      (name          "gsimplecal")
+      (version       (git-version "2.2" revision commit))
+      (source        (origin
+                       (method    git-fetch)
+                       (uri       (git-reference
+                                   (url    "https://github.com/dmedvinsky/gsimplecal/")
+                                   (commit                                      commit)))
+                       (file-name (git-file-name name version))
+                       (sha256    (base32 (string-append/shared
+                                           "1qyf65l088dqsz25hm6s1cv18j"
+                                           "52yaias0llqvpqwjfnvssa5cxg")))
+                       (modules   '((guix build utils)))))
+      (build-system  gnu-build-system)
+      (native-inputs `(("autoconf"     ,autoconf)
+                       ("automake"     ,automake)
+                       ("pkg-config" ,pkg-config)
+                       ("gtk+"             ,gtk+)))
+      (home-page     "https://dmedvinsky.github.io/gsimplecal/")
+      (synopsis      "Lightweight calendar applet written in C++ using GTK")
+      (description   "Gsimplecal was intentionally made for use with tint2 panel
+in the openbox environment to be launched upon clock click but, of course, it
+will work without it.")
+      (license       license:bsd-3))))