diff mbox series

[bug#52030] gnu: Add feather font

Message ID DM6PR19MB246009FC1A233E37685B9112999F9@DM6PR19MB2460.namprd19.prod.outlook.com
State Accepted
Headers show
Series [bug#52030] gnu: Add feather font | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Wamm K. D Nov. 22, 2021, 4:26 a.m. UTC
* gnu/packages/fonts.scm (feather): Add Feather iconfont by AT-UI

The foundry, AT-UI, has a hyphen but https://guix.gnu.org/manual/en/html_node/Fonts.html
seems to implicitly imply the foundry wouldn't have hyphens so I removed them,
for the package name (font-atui-feather).

---
gnu/packages/fonts.scm | 17 +++++++++++++++++
1 file changed, 17 insertions(+)

Comments

Ludovic Courtès Dec. 10, 2021, 2:28 p.m. UTC | #1
Hi Jaft,

Jaft <jaft.r@outlook.com> skribis:

> * gnu/packages/fonts.scm (feather): Add Feather iconfont by AT-UI
>
> The foundry, AT-UI, has a hyphen but https://guix.gnu.org/manual/en/html_node/Fonts.html
> seems to implicitly imply the foundry wouldn't have hyphens so I removed them,
> for the package name (font-atui-feather).

I think it’s fine either way.

> +    (name "font-atui-feather")
> +    (version "0")
> +    (source (origin
> +              (method url-fetch/zipbomb)
> +              (uri "https://github.com/AT-UI/feather-font/archive/refs/heads/master.zip")
> +              (sha256 (base32 "0lp1m1a47s56rj0q6nj8j5snkbw8jq3q7zwdzf86sbbglq170inh"))))

Note that ‘master.zip’ changes at each commit (and its content can also
change even if the HEAD commit is unchanged because it’s a generated
file.)

Could you instead change it to refer to a non-generated zip file, or use
‘git-fetch’ to obtain a checkout?

You may also need to adjust the version string.

> +    (build-system font-build-system)
> +    (home-page "https://at-ui.github.io/feather-font/")
> +    (synopsis "Iconfont version of Feather")
> +    (description "Feather is a collection of simply beautiful open source icons.

Everything is free software/data in Guix, so you can remove “open
source”.  :-)

Could you send an updated patch?  Preferably as a attachment to make
sure it’s not mangled on its way.

Thanks in advance!

Ludo’.
Wamm K. D Feb. 27, 2022, 3:32 a.m. UTC | #2
I don't know if it's generally considered poor etiquette to do this but just bumping this E-mail thread, as I believe I've done the required changes and, theoretically, this patch should be all ready to just go.
diff mbox series

Patch

diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index c3ad57f203..2a46e08d9d 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -42,6 +42,7 @@ 
 ;;; Copyright © 2021 Sergiu Ivanov <sivanov@colimite.fr>
 ;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
 ;;; Copyright © 2021 Paul A. Patience <paul@apatience.com>
+;;; Copyright © 2021 Wamm K. D. <jaft.r@outlook.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -2285,3 +2286,19 @@  (define-public font-overpass
 Overpass includes proportional and monospace variants.")
     (license (list license:silofl1.1
                    license:lgpl2.1))))
+
+(define-public font-atui-feather
+  (package
+    (name "font-atui-feather")
+    (version "0")
+    (source (origin
+              (method url-fetch/zipbomb)
+              (uri "https://github.com/AT-UI/feather-font/archive/refs/heads/master.zip")
+              (sha256 (base32 "0lp1m1a47s56rj0q6nj8j5snkbw8jq3q7zwdzf86sbbglq170inh"))))
+    (build-system font-build-system)
+    (home-page "https://at-ui.github.io/feather-font/")
+    (synopsis "Iconfont version of Feather")
+    (description "Feather is a collection of simply beautiful open source icons.
+Each icon is designed on a 24x24 grid with an emphasis on simplicity, consistency,
+and readability.  This package bundles those icons into a font.")
+    (license license:expat)))