diff mbox series

[bug#42808] gnu: python-lxml: Update to 4.5.2.

Message ID DM5PR1001MB2105F8C1229737690A29A960C5450@DM5PR1001MB2105.namprd10.prod.outlook.com
State Accepted
Headers show
Series [bug#42808] gnu: python-lxml: Update to 4.5.2. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Morgan Smith Aug. 11, 2020, 2:51 a.m. UTC
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/xml.scm (python-lxml): Update to 4.5.2.
---
Am I supposed to add copyright for stuff this small?


 gnu/packages/xml.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Mathieu Othacehe Aug. 13, 2020, 8:31 a.m. UTC | #1
Hello,

> * gnu/packages/xml.scm (python-lxml): Update to 4.5.2.
> ---
> Am I supposed to add copyright for stuff this small?

No it's fine. However this change triggers many rebuilds so I had to
apply it on core-updates.

Thanks,

Mathieu
Oleg Pykhalov Aug. 14, 2020, 1:22 p.m. UTC | #2
Hi,

Morgan.J.Smith@outlook.com writes:

> From: Morgan Smith <Morgan.J.Smith@outlook.com>
>
> * gnu/packages/xml.scm (python-lxml): Update to 4.5.2.
> ---
> Am I supposed to add copyright for stuff this small?

You supposed to add the copyright only in the file you changed.

>  gnu/packages/xml.scm | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
> index 20d9de246c..05e5f532b2 100644
> --- a/gnu/packages/xml.scm
> +++ b/gnu/packages/xml.scm
> @@ -2152,13 +2152,13 @@ because lxml.etree already has it's own implementation of XPath 1.0.")

[…]

Thank you for the patch!

However the package update already present in core-updates [1] and will
be applied after the merge.

[1] https://git.savannah.gnu.org/cgit/guix.git/commit/?id=8b074a0abef78341d98ac4ca8e6f27bfcc7aa65b

Regars,
Oleg.
diff mbox series

Patch

diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 20d9de246c..05e5f532b2 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -2152,13 +2152,13 @@  because lxml.etree already has it's own implementation of XPath 1.0.")
 (define-public python-lxml
   (package
     (name "python-lxml")
-    (version "4.4.2")
+    (version "4.5.2")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "lxml" version))
        (sha256
-        (base32 "01nvb5j8vs9nk4z5s3250b1m22b4d08kffa36if3g1mdygdrvxpg"))))
+        (base32 "1xhx76hr1w3lllfcg9a01f2y0zwyf59ijnvlh08299mjh8b3mhfd"))))
     (build-system python-build-system)
     (arguments
      `(#:phases (modify-phases %standard-phases