diff mbox series

[bug#43422] gnu: Add emacs-eshell-syntax-highlighting.

Message ID DM5PR1001MB2105D0062841517680280DD8C5200@DM5PR1001MB2105.namprd10.prod.outlook.com
State Accepted
Headers show
Series [bug#43422] gnu: Add emacs-eshell-syntax-highlighting. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Morgan Smith Sept. 15, 2020, 12:57 p.m. UTC
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/emacs-xyz.scm (emacs-eshell-syntax-highlighting): New variable.
---
 gnu/packages/emacs-xyz.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)

Comments

Nicolas Goaziou Sept. 16, 2020, 8:07 p.m. UTC | #1
Hello,

Morgan.J.Smith@outlook.com writes:

> * gnu/packages/emacs-xyz.scm (emacs-eshell-syntax-highlighting): New
> variable.

Thank you.

I tweaked indentation a bit, replaced @code{eshell} with Eshell, and
applied your patch.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 46af73456b..238ee15ef2 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -16924,6 +16924,26 @@  visiting the bookmark, a new @code{eshell} session will be opened in the
 appropriate directory if no @code{eshell} session is active.")
     (license license:gpl3+)))
 
+(define-public emacs-eshell-syntax-highlighting
+  (package
+    (name "emacs-eshell-syntax-highlighting")
+    (version "0.2")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/akreisher/eshell-syntax-highlighting")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0id27874wsb5y169030x8g1ldpa1mnskv1s2j3ygqiyh5fvpfash"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/akreisher/eshell-syntax-highlighting")
+    (synopsis "Adds syntax highlighting to @code{eshell}")
+    (description "This package highlights user commands at the @code{eshell}
+interactive prompt to provide feedback on the validity of commands and syntax.")
+    (license license:gpl3+)))
+
 (define-public emacs-eshell-z
   (package
     (name "emacs-eshell-z")