diff mbox series

[bug#43197] gnu: Add emacs-org-edna.

Message ID DM5PR1001MB2105C8F16D7D6909F7274868C52D0@DM5PR1001MB2105.namprd10.prod.outlook.com
State Accepted
Headers show
Series [bug#43197] gnu: Add emacs-org-edna. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Morgan Smith Sept. 4, 2020, 5:01 a.m. UTC
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/emacs-xyz.scm (emacs-org-edna): New variable.
---
 gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

Comments

Mathieu Othacehe Sept. 4, 2020, 9:47 a.m. UTC | #1
> * gnu/packages/emacs-xyz.scm (emacs-org-edna): New variable.

Pushed with a slightly edited description.

Thanks,

Mathieu
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 3482686ccd..3802ddddf3 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -9663,6 +9663,28 @@  lists, and project planning with a fast and effective plain-text system.
 This package is equivalent to org-plus-contrib, but only includes additional
 files that you would find in @file{contrib/} from the git repository.")))
 
+(define-public emacs-org-edna
+  (package
+    (name "emacs-org-edna")
+    (version "1.1.2")
+    (source (origin
+              (method bzr-fetch)
+              (uri (bzr-reference
+                    (url "bzr://bzr.savannah.nongnu.org/org-edna-el")
+                    (revision version)))
+              (file-name (string-append name "-" version "-checkout"))
+              (sha256
+               (base32
+                "01dblddgx0yid5hrgl4swbr4grhv057kfbdy122wihzqpsrgq86n"))))
+    (build-system emacs-build-system)
+    (home-page "https://savannah.nongnu.org/projects/org-edna-el/")
+    (synopsis "Manages Org task dependencies")
+    (description "Provides an extensible means of specifying conditions which
+must be fulfilled before a task can be completed and actions to take once it
+is.  Org Edna runs when either the BLOCKER or TRIGGER properties are set on a
+heading, and when it is changing from a TODO state to a DONE state.")
+    (license license:gpl3+)))
+
 (define-public emacs-flx
   (package
     (name "emacs-flx")