diff mbox series

[bug#41567] gnu: Add mspdebug.

Message ID DM5PR1001MB2105C89D713D8507F978DC08C5B10@DM5PR1001MB2105.namprd10.prod.outlook.com
State Accepted
Headers show
Series [bug#41567] gnu: Add mspdebug. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Morgan Smith May 27, 2020, 5:34 p.m. UTC
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/mspdebug.scm (mspdebug): New variable.
---
 gnu/packages/mspdebug.scm | 44 +++++++++++++++++++++++++++++++++++++++
 1 file changed, 44 insertions(+)
 create mode 100644 gnu/packages/mspdebug.scm

Comments

Marius Bakke May 30, 2020, 1:53 p.m. UTC | #1
Morgan.J.Smith@outlook.com writes:

> From: Morgan Smith <Morgan.J.Smith@outlook.com>
>
> * gnu/packages/mspdebug.scm (mspdebug): New variable.

Can you move this package to gnu/packages/debug.scm instead of adding a
new module?

[...]

> +(define-public mspdebug
> +  (package
> +    (name "mspdebug")
> +    (version "0.25")
> +    (source (origin
> +              (method git-fetch)
> +              (uri (git-reference
> +                    (url "https://github.com/dlbeer/mspdebug.git")
> +                    (commit (string-append "v" version))))
> +              (file-name (git-file-name name version))
> +              (sha256
> +               (base32 "0prgwb5vx6fd4bj12ss1bbb6axj2kjyriyjxqrzd58s5jyyy8d3c"))))
> +    (build-system gnu-build-system)
> +    (arguments
> +     `(#:phases (modify-phases %standard-phases (delete 'configure) (delete 'check))
> +       #:make-flags
> +       (let ((target ,(%current-target-system)))
> +         (list (string-append "CC=" (if target
> +                                        (string-append target "-gcc")
> +                                        "gcc"))

Since very recently, you can now use:

  (string-append "CC=" ,(cc-for-target))

instead of the let binding and conditional.

> +               "INSTALL=install"
> +               (string-append "PREFIX=" %output)))))
> +    (inputs
> +     `(("libusb-compat" ,libusb-compat)
> +       ("readline" ,readline)))
> +    (synopsis "Free debugger for use with MSP430 MCUs")

No need to mention free here, since everything in Guix is free
software.  The GitHub tagline is pretty good:

  Debugging tool for MSP430 MCUs

> +    (description "MspDebug supports FET430UIF, eZ430, RF2500 and Olimex
> +MSP430-JTAG-TINY programmers, as well as many other compatible
> +devices.  It can be used as a proxy for gdb or as an independent
> +debugger with support for programming, disassembly and reverse
> +engineering.")
> +    (home-page "https://github.com/dlbeer/mspdebug")
> +    (license gpl2)))

This should be 'gpl2+', since the source files say "GPL 2 or any later
version".

Can you send an updated patch?  Thanks in advance!
ashish.is--- via Guix-patches" via May 30, 2020, 7:03 p.m. UTC | #2
Morgan,

Morgan.J.Smith@outlook.com 写道:
> +     `(#:phases (modify-phases %standard-phases (delete 
> 'configure) (delete 'check))

Try to keep lines within 80 characters.  Have you heard of our 
lord & saviour ‘guix lint’?  It's nitpicking like this, automated.

There's a more ‘declarative’ way to disable tests.  Add a short 
note why:

  `(#:tests? #f                         ; no test suite
    #:phases
    (modify-phases %standard-phases
      (delete 'configure)))             ; no configure script

Kind regards,

T G-R
diff mbox series

Patch

diff --git a/gnu/packages/mspdebug.scm b/gnu/packages/mspdebug.scm
new file mode 100644
index 0000000000..fcabcae472
--- /dev/null
+++ b/gnu/packages/mspdebug.scm
@@ -0,0 +1,44 @@ 
+;;; Copyright © 2020 Morgan Smith <Morgan.J.Smith@outlook.com>
+
+(define-module (gnu packages mspdebug)
+  #:use-module (guix packages)
+  #:use-module (guix git-download)
+  #:use-module (guix build-system gnu)
+  #:use-module (guix licenses)
+  #:use-module (gnu packages libusb)
+  #:use-module (gnu packages readline))
+
+
+(define-public mspdebug
+  (package
+    (name "mspdebug")
+    (version "0.25")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/dlbeer/mspdebug.git")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32 "0prgwb5vx6fd4bj12ss1bbb6axj2kjyriyjxqrzd58s5jyyy8d3c"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:phases (modify-phases %standard-phases (delete 'configure) (delete 'check))
+       #:make-flags
+       (let ((target ,(%current-target-system)))
+         (list (string-append "CC=" (if target
+                                        (string-append target "-gcc")
+                                        "gcc"))
+               "INSTALL=install"
+               (string-append "PREFIX=" %output)))))
+    (inputs
+     `(("libusb-compat" ,libusb-compat)
+       ("readline" ,readline)))
+    (synopsis "Free debugger for use with MSP430 MCUs")
+    (description "MspDebug supports FET430UIF, eZ430, RF2500 and Olimex
+MSP430-JTAG-TINY programmers, as well as many other compatible
+devices.  It can be used as a proxy for gdb or as an independent
+debugger with support for programming, disassembly and reverse
+engineering.")
+    (home-page "https://github.com/dlbeer/mspdebug")
+    (license gpl2)))