diff mbox series

[bug#43046] gnu: Add emacs-auth-source-xoauth2.

Message ID DM5PR1001MB210581BBAD98B2EED92335DFC5570@DM5PR1001MB2105.namprd10.prod.outlook.com
State Accepted
Headers show
Series [bug#43046] gnu: Add emacs-auth-source-xoauth2. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Morgan Smith Aug. 25, 2020, 5:29 p.m. UTC
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/emacs-xyz.scm (emacs-auth-source-xoauth2): New variable.
---
 gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

Comments

Nicolas Goaziou Aug. 27, 2020, 1:26 p.m. UTC | #1
Hello,

Morgan.J.Smith@outlook.com writes:

> From: Morgan Smith <Morgan.J.Smith@outlook.com>
>
> * gnu/packages/emacs-xyz.scm (emacs-auth-source-xoauth2): New
> variable.

Thank you.

I fixed indentation, slightly reworded the description and the synopsis,
and pushed.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 62c9203efc..997d655683 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -12474,6 +12474,30 @@  needs to be refreshed, the code handles it automatically and stores the new
 value of the access token.")
     (license license:gpl3+)))
 
+(define-public emacs-auth-source-xoauth2
+  (package
+    (name "emacs-auth-source-xoauth2")
+    (version "1.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/ccrusius/auth-source-xoauth2")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "0nl859csl8xcd6ybpjj15ph8l8fxwkwf45kbylss68alkyf1rl3v"))))
+     (build-system emacs-build-system)
+     (home-page "https://github.com/ccrusius/auth-source-xoauth2")
+     (synopsis "Adds @code{XOAuth2} authentication capabilities to Emacs
+@code{auth-source}")
+     (description "Adds @code{XOAuth2} authentication capabilities to Emacs
+@code{auth-source}.  This integration requires some preliminary work on the
+users’ part, which includes creating tokens. For more details, @code{M-x
+describe-variable auth-source-xoauth2-creds}.")
+     (license license:asl2.0)))
+
 (define-public emacs-circe
   (package
     (name "emacs-circe")