diff mbox series

[bug#43910] gnu: emacs-modus-vivendi-theme: Update to 0.13.0.

Message ID DM5PR1001MB210520D021E476DE3ACB101BC5090@DM5PR1001MB2105.namprd10.prod.outlook.com
State Accepted
Headers show
Series [bug#43910] gnu: emacs-modus-vivendi-theme: Update to 0.13.0. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Morgan Smith Oct. 10, 2020, 4 p.m. UTC
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/emacs-xyz.scm (emacs-modus-vivendi-theme): Update to 0.13.0.
[source]: Use git instead of elpa, as elpa is out of date
[arguments]: Add phase to remove modus-operandi-theme.el
---
 gnu/packages/emacs-xyz.scm | 20 +++++++++++++++-----
 1 file changed, 15 insertions(+), 5 deletions(-)

Comments

Nicolas Goaziou Oct. 11, 2020, 4:25 p.m. UTC | #1
Hello,

Morgan.J.Smith@outlook.com writes:

> * gnu/packages/emacs-xyz.scm (emacs-modus-vivendi-theme): Update to 0.13.0.
> [source]: Use git instead of elpa, as elpa is out of date
> [arguments]: Add phase to remove modus-operandi-theme.el

Thank you.

However I suggest we stick to GNU ELPA repository, since it makes the
package much easier to update. Also, GNU ELPA will eventually catch up
with the new version.

WDYT?

Regards,
Morgan Smith Oct. 11, 2020, 4:33 p.m. UTC | #2
I was thinking the author likely stopped updating elpa once his package
made it into mainline emacs (but not in time for 27.1). I guess I'll
reach out and let him know he should keep updating it for a bit.

Also I remembered someone telling me to not use elpa. Upon checking the
history, you warned me about melpa, not elpa.

Cheers!
André A. Gomes Oct. 30, 2020, 6:16 p.m. UTC | #3
Hi,

You may find the following discussion useful:

https://gitlab.com/protesilaos/modus-themes/-/issues/111

So it seems that Guix will wait for GNU ELPA to release the latest
version, correct?
Protesilaos Stavrou Oct. 31, 2020, 5:07 a.m. UTC | #4
Hello everyone,

Just to note that I have not abandoned GNU ELPA: it remains an important
target.

The delay for this version is due to administrative changes that need to
happen.  The themes are now part of GNU Emacs, so GNU ELPA must be
patched to get them from emacs.git (together with their new Info
manual).

I do not have push access to GNU ELPA and must thus coordinate with the
maintainer.  Once this is done, future updates will not go through any
delays.

Thank you for your understanding!

Best regards,
Protesilaos
Ludovic Courtès Nov. 2, 2020, 1:50 p.m. UTC | #5
Hi,

Nicolas, Morgan: what’s the status of this patch?

TIA! :-)

Ludo’.

Morgan Smith <Morgan.J.Smith@outlook.com> skribis:

> I was thinking the author likely stopped updating elpa once his package
> made it into mainline emacs (but not in time for 27.1). I guess I'll
> reach out and let him know he should keep updating it for a bit.
>
> Also I remembered someone telling me to not use elpa. Upon checking the
> history, you warned me about melpa, not elpa.
>
> Cheers!
Morgan Smith Nov. 2, 2020, 2:19 p.m. UTC | #6
Hi Ludo,

So I really want it to be applied as is so I can use package
transformations and build this package from master (Currently if you try
to use package transformations you will obtain an extra unwanted file).
However, for some reason (I still don't know why) we like to use elpa.

If we do really want to keep using elpa (someone please explain to me
the benefits of doing this) than the good news is the author is working
on it and we just have to be patient. The moment this link says 0.13
instead of 0.12, we can do a version bump:
https://elpa.gnu.org/packages/modus-operandi-theme.html

Morgan

On 11/2/20 8:50 AM, Ludovic Courtès wrote:
> Hi,
> 
> Nicolas, Morgan: what’s the status of this patch?
> 
> TIA! :-)
> 
> Ludo’.
> 
> Morgan Smith <Morgan.J.Smith@outlook.com> skribis:
> 
>> I was thinking the author likely stopped updating elpa once his package
>> made it into mainline emacs (but not in time for 27.1). I guess I'll
>> reach out and let him know he should keep updating it for a bit.
>>
>> Also I remembered someone telling me to not use elpa. Upon checking the
>> history, you warned me about melpa, not elpa.
>>
>> Cheers!
Nicolas Goaziou Nov. 2, 2020, 6:33 p.m. UTC | #7
Hello,

Morgan Smith <Morgan.J.Smith@outlook.com> writes:

> If we do really want to keep using elpa (someone please explain to me
> the benefits of doing this) than the good news is the author is working
> on it and we just have to be patient. The moment this link says 0.13
> instead of 0.12, we can do a version bump:
> https://elpa.gnu.org/packages/modus-operandi-theme.html

GNU ELPA is preferred because updating the package is much easier. This
is important when you have lot of packages you want to keep up-to-date.
It is also easier to get notified about updates, but that's not specific
to Guix.

Usually, GNU ELPA catches up releases quickly, but it seems more
complicated in this case. So, I think it is reasonable to update this
package using GitHub source and switch back to ELPA when the situation
is sorted out.

Regards,
Nicolas Goaziou Nov. 3, 2020, 11:01 a.m. UTC | #8
Hello,

Morgan.J.Smith@outlook.com writes:

> * gnu/packages/emacs-xyz.scm (emacs-modus-vivendi-theme): Update to 0.13.0.
> [source]: Use git instead of elpa, as elpa is out of date
> [arguments]: Add phase to remove modus-operandi-theme.el

Applied. Thank you.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 44aaaa0541..f1ebdd90ff 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -22685,15 +22685,25 @@  standard.  This is the highest standard of its kind.")
 (define-public emacs-modus-vivendi-theme
   (package
     (name "emacs-modus-vivendi-theme")
-    (version "0.12.0")
+    (version "0.13.0")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append "https://elpa.gnu.org/packages/"
-                           "modus-vivendi-theme-" version ".el"))
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://gitlab.com/protesilaos/modus-themes")
+             (commit version)))
+       (file-name (git-file-name name version))
        (sha256
-        (base32 "01f6z5xjnmki1k9m83jwva42lxidb31pdpwm4wpxjzxqmb96picn"))))
+        (base32
+         "0i6n3pzrmlgabsijy6z0hhs71q7g99yagwr2m33lr30skqc9rvdn"))))
     (build-system emacs-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'remove-other-theme
+           (lambda _
+             (delete-file "modus-operandi-theme.el")
+             #t)))))
     (home-page "https://gitlab.com/protesilaos/modus-themes")
     (synopsis "Accessible dark theme (WCAG AAA)")
     (description